summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJelle van der Waa2020-08-03 19:20:18 +0000
committerJelle van der Waa2020-08-03 19:20:18 +0000
commit0200989050c8c09636f06df83b164789206c59b2 (patch)
treeb305d059a0403db61c38a99d79d6bd76e8149955
parentbe7f3e7f086e32842b8488812cea0c364dd4b5ad (diff)
downloadaur-0200989050c8c09636f06df83b164789206c59b2.tar.gz
Fix FS#67465 and FS#67466
Switch to boost license in licenses as the licenses package provides it and set VERSION define to dump the version in the pkgconf file.
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55e115c0696b..4621dfe01d9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
pkgname=polyclipping
pkgver=6.4.2
-pkgrel=3
+pkgrel=4
pkgdesc="Polygon clipping library"
arch=('x86_64')
url="https://sourceforge.net/projects/polyclipping/"
-license=('custom')
+license=('Boost')
depends=('gcc-libs')
makedepends=('cmake')
source=("https://downloads.sourceforge.net/polyclipping/clipper_ver${pkgver}.zip")
@@ -15,7 +15,7 @@ sha256sums=('a14320d82194807c4480ce59c98aa71cd4175a5156645c4e2b3edd330b930627')
build() {
cd "${srcdir}"
mkdir -p build && cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ../cpp
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DVERSION=$pkgver ../cpp
make
}
@@ -23,7 +23,4 @@ package() {
cd "${srcdir}/build"
make install DESTDIR="$pkgdir"
install -d "$pkgdir/usr/share/licenses/$pkgname"
-
- cd "${srcdir}"
- install -Dm644 License.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}