summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2015-11-30 14:52:46 +0100
committerMarco Pompili2015-11-30 17:14:49 +0100
commitb03d85489c1b720157ebaed3112b6a111a3ef7af (patch)
tree167db104bda2e2da628b1b7ef029c32b077ff6c7
downloadaur-b03d85489c1b720157ebaed3112b6a111a3ef7af.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD142
-rw-r--r--arch_link_fix_debug.diff29
-rw-r--r--arch_link_fix_release.diff29
-rw-r--r--polycode.desktop12
6 files changed, 243 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1fb239777b56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = polycode
+ pkgdesc = A C++ and Lua framework for building interactive applications.
+ pkgver = 0.8.4
+ pkgrel = 1
+ url = http://polycode.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = python2-ply
+ makedepends = ninja
+ makedepends = doxygen
+ depends = lua52
+ depends = sdl
+ depends = glu
+ depends = openal
+ source = http://polycode.org/download/content/Polycode-0.8.4.zip
+ source = arch_link_fix_debug.diff
+ source = arch_link_fix_release.diff
+ source = polycode.desktop
+ md5sums = e42120831f8b84a0d374d4084c462b43
+ md5sums = fcea2ec5bd60406b93418ba9c2153e8c
+ md5sums = 31bd18ce087aa3f773219c28b98af834
+ md5sums = 1e8bd5317383fb390c7cf017cfc3fb11
+
+pkgname = polycode
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8804c01aad1e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+Polycode-*
+polycode-*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60f0b2fa565c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,142 @@
+#Contributor: Marco Pompili <marcs.pompili@gmail.com>
+#Maintainer: Marco Pompili <marcs.pompili@gmail.com>
+
+pkgname=polycode
+pkgver=0.8.4
+pkgrel=1
+pkgdesc="A C++ and Lua framework for building interactive applications."
+arch=('i686' 'x86_64')
+url='http://polycode.org/'
+license=('MIT')
+depends=('lua52' 'sdl' 'glu' 'openal')
+makedepends=('cmake' 'python2-ply' 'ninja' 'doxygen')
+source=('http://polycode.org/download/content/Polycode-0.8.4.zip'
+ 'arch_link_fix_debug.diff'
+ 'arch_link_fix_release.diff'
+ 'polycode.desktop')
+md5sums=('e42120831f8b84a0d374d4084c462b43'
+ 'fcea2ec5bd60406b93418ba9c2153e8c'
+ '31bd18ce087aa3f773219c28b98af834'
+ '1e8bd5317383fb390c7cf017cfc3fb11')
+
+prepare() {
+ cd Polycode-master
+
+ mkdir -p Dependencies/Build/Debug \
+ Dependencies/Build/Release \
+ Build/Debug \
+ Build/Release \
+ Standalone/Build
+}
+
+build() {
+ cd Polycode-master
+
+ msg2 "Building Dependencies (Debug)"
+ cd Dependencies/Build/Debug
+ cmake -G "Ninja" -DCMAKE_BUILD_TYPE=Debug ../..
+ ninja
+
+ msg2 "Building Dependencies (Release)"
+ cd ../Release
+ cmake -G "Ninja" -DCMAKE_BUILD_TYPE=Release ../..
+ ninja
+
+ msg2 "Building Polycode (Debug)"
+ cd ../../../Build/Debug
+ cmake -G "Ninja" \
+ -DPOLYCODE_BUILD_BINDINGS=ON \
+ -DPOLYCODE_BUILD_PLAYER=ON \
+ -DCMAKE_BUILD_TYPE=Debug \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 ../..
+
+ msg2 "Link fix patch for Arch (Debug)"
+ patch -p1 < $srcdir/arch_link_fix_debug.diff build.ninja
+ ninja
+ ninja install
+
+ msg2 "Building Polycode (Release)"
+ cd ../Release
+ cmake -G "Ninja" \
+ -DPOLYCODE_BUILD_BINDINGS=ON \
+ -DPOLYCODE_BUILD_PLAYER=ON \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 ../..
+
+ msg2 "Link fix patch for Arch (Release)"
+ patch -p1 < $srcdir/arch_link_fix_release.diff build.ninja
+ ninja
+ ninja install
+
+ msg2 "Making Standalone Install"
+ cd ../../Standalone/Build
+ cmake -G "Ninja" ..
+ ninja
+ ninja install
+
+ msg2 "Building Polycode IDE"
+ cd ../../IDE/Build/Linux
+ make
+}
+
+package() {
+ cd Polycode-master
+
+ install -dm755 $pkgdir/opt/$pkgname
+
+ #cp -R Release/Linux/Framework/Bindings $pkgdir/opt/$pkgname
+
+ msg2 "Packaging Core"
+ install -dm755 $pkgdir/opt/$pkgname/Core
+ cp -R Release/Linux/Framework/Core/Assets $pkgdir/opt/$pkgname/Core
+
+ # Dependencies
+ install -dm755 $pkgdir/opt/$pkgname/Core/Dependencies
+ cp -R Release/Linux/Framework/Core/Dependencies/include \
+ $pkgdir/opt/$pkgname/Core/Dependencies/
+
+ install -dm755 $pkgdir/opt/$pkgname/Core/Dependencies/lib
+ find Release/Linux/Framework/Core/Dependencies/lib/ \
+ -maxdepth 1 -type f -exec cp {} $pkgdir/opt/$pkgname/Core/Dependencies/lib \;
+
+ # includes libs and view
+ cp -R Release/Linux/Framework/Core/include $pkgdir/opt/$pkgname/Core
+ cp -R Release/Linux/Framework/Core/lib $pkgdir/opt/$pkgname/lib
+ cp -R Release/Linux/Framework/Core/PolycodeView $pkgdir/opt/$pkgname/Core
+
+ # modules
+ install -dm755 $pkgdir/opt/$pkgname/Modules
+ cp -R Release/Linux/Framework/Modules/include $pkgdir/opt/$pkgname/Modules/include
+
+ install -dm755 $pkgdir/opt/$pkgname/Modules/lib
+ find Release/Linux/Framework/Modules/lib/ \
+ -maxdepth 1 -type f -exec cp {} $pkgdir/opt/$pkgname/Modules/lib \;
+
+ # examples player template
+ cp -R Release/Linux/Framework/Examples $pkgdir/opt/$pkgname
+ cp -R Release/Linux/Framework/Player $pkgdir/opt/$pkgname
+ cp -R Release/Linux/Framework/Template $pkgdir/opt/$pkgname
+
+ #cp -R Release/Linux/Framework/Tools $pkgdir/opt/$pkgname
+
+ msg2 "Packaging Polycode IDE"
+ cp -R IDE/Build/Linux/Build $pkgdir/opt/$pkgname
+ mv $pkgdir/opt/$pkgname/Build $pkgdir/opt/$pkgname/IDE
+
+ msg2 "Packaging Utils"
+ install -dm755 $pkgdir/usr/bin
+ install -m755 Release/Linux/Standalone/Bin/polybuild $pkgdir/usr/bin/polybuild
+ install -m755 Release/Linux/Standalone/Bin/polyimport $pkgdir/usr/bin/polyimport
+
+ msg2 "Packaging Standalone"
+ install -dm755 $pkgdir/usr/lib/$pkgname
+ cp -R Release/Linux/Standalone/Player $pkgdir/usr/lib/$pkgname
+ cp -R Release/Linux/Standalone/Publish $pkgdir/usr/lib/$pkgname
+ cp -R Release/Linux/Standalone/Template $pkgdir/usr/lib/$pkgname
+
+ install -dm755 $pkgdir/usr/share/applications
+ install -m644 ../polycode.desktop $pkgdir/usr/share/applications/polycode.desktop
+
+ install -dm755 $pkgdir/usr/share/licenses/$pkgname
+ install -m644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/arch_link_fix_debug.diff b/arch_link_fix_debug.diff
new file mode 100644
index 000000000000..a81393e49ca1
--- /dev/null
+++ b/arch_link_fix_debug.diff
@@ -0,0 +1,29 @@
+--- build.ninja 2015-11-30 14:44:03.855256624 +0100
++++ build.ninja.arch 2015-11-30 14:42:57.645931704 +0100
+@@ -6,7 +6,7 @@
+
+ # =============================================================================
+ # Write statements declared in CMakeLists.txt:
+-#
++#
+ # Which is the root file.
+ # =============================================================================
+
+@@ -1365,7 +1365,7 @@
+
+ build Player/Contents/PolycodePlayer: CXX_EXECUTABLE_LINKER__PolycodePlayer Player/Contents/CMakeFiles/PolycodePlayer.dir/Source/PolycodePlayer.cpp.o Player/Contents/CMakeFiles/PolycodePlayer.dir/Source/PolycodeLinuxPlayer.cpp.o Player/Contents/CMakeFiles/PolycodePlayer.dir/Platform/Linux/main.cpp.o | Bindings/Contents/LUA/libPolycodeLua_d.a Core/Contents/libPolycore_d.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblua5.1.a ../../Release/Linux/Framework/Core/Dependencies/lib/libfreetype.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbisfile.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbis.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibogg.a ../../Release/Linux/Framework/Core/Dependencies/lib/libopenal.so ../../Release/Linux/Framework/Core/Dependencies/lib/libphysfs.a ../../Release/Linux/Framework/Core/Dependencies/lib/libpng15d.a ../../Release/Linux/Framework/Core/Dependencies/lib/libz.a /usr/lib64/libGLU.so /usr/lib64/libGL.so /usr/lib64/libSDL.so Modules/Bindings/2DPhysics/Physics2DLua_d.a Modules/Bindings/3DPhysics/Physics3DLua_d.a Modules/Bindings/UI/UILua_d.a Modules/Contents/2DPhysics/libPolycode2DPhysics_d.a Modules/Contents/3DPhysics/libPolycode3DPhysics_d.a Modules/Contents/UI/libPolycodeUI_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBox2D.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletMultiThreaded_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletSoftBody_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletDynamics_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletCollision_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libLinearMath_d.a Core/Contents/libPolycore_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBox2D_d.a ../../Release/Linux/Framework/Core/Dependencies/lib/libfreetype.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbisfile.a ../../Release/Linux/Framework/Core/Dependencies/lib/libopenal.so ../../Release/Linux/Framework/Core/Dependencies/lib/libphysfs.a ../../Release/Linux/Framework/Core/Dependencies/lib/libpng15d.a /usr/lib64/libGLU.so /usr/lib64/libGL.so || Core/Contents/libPolycore_d.a Bindings/Contents/LUA/libPolycodeLua_d.a Modules/Contents/2DPhysics/libPolycode2DPhysics_d.a Modules/Contents/3DPhysics/libPolycode3DPhysics_d.a Modules/Contents/UI/libPolycodeUI_d.a Modules/Bindings/2DPhysics/Physics2DLua_d.a Modules/Bindings/3DPhysics/Physics3DLua_d.a Modules/Bindings/UI/UILua_d.a
+ FLAGS = -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -g
+- LINK_FLAGS = -Wl,-O1,--sort-common,--as-needed,-z,relro
++ LINK_FLAGS = -lX11 -lxcb -Wl,-O1,--sort-common,--as-needed,-z,relro
+ LINK_LIBRARIES = -rdynamic -lrt -lpthread Bindings/Contents/LUA/libPolycodeLua_d.a Core/Contents/libPolycore_d.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblua5.1.a ../../Release/Linux/Framework/Core/Dependencies/lib/libfreetype.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbisfile.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbis.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibogg.a ../../Release/Linux/Framework/Core/Dependencies/lib/libopenal.so ../../Release/Linux/Framework/Core/Dependencies/lib/libphysfs.a ../../Release/Linux/Framework/Core/Dependencies/lib/libpng15d.a ../../Release/Linux/Framework/Core/Dependencies/lib/libz.a -lGLU -lGL -lSDL -ldl Modules/Bindings/2DPhysics/Physics2DLua_d.a Modules/Bindings/3DPhysics/Physics3DLua_d.a Modules/Bindings/UI/UILua_d.a Modules/Contents/2DPhysics/libPolycode2DPhysics_d.a Modules/Contents/3DPhysics/libPolycode3DPhysics_d.a Modules/Contents/UI/libPolycodeUI_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBox2D.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletMultiThreaded_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletSoftBody_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletDynamics_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletCollision_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libLinearMath_d.a Core/Contents/libPolycore_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBox2D_d.a ../../Release/Linux/Framework/Core/Dependencies/lib/libfreetype.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbisfile.a ../../Release/Linux/Framework/Core/Dependencies/lib/libopenal.so ../../Release/Linux/Framework/Core/Dependencies/lib/libphysfs.a ../../Release/Linux/Framework/Core/Dependencies/lib/libpng15d.a -lGLU -lGL -Wl,-rpath,/home/marcs/Arch/AUR/polycode/src/Polycode-master/Release/Linux/Framework/Core/Dependencies/lib:
+ OBJECT_DIR = Player/Contents/CMakeFiles/PolycodePlayer.dir
+ POST_BUILD = :
+@@ -1411,7 +1411,7 @@
+
+ build Player/Contents/StandalonePlayer: CXX_EXECUTABLE_LINKER__StandalonePlayer Player/Contents/CMakeFiles/StandalonePlayer.dir/Source/PolycodePlayer.cpp.o Player/Contents/CMakeFiles/StandalonePlayer.dir/Source/PolycodeLinuxPlayer.cpp.o Player/Contents/CMakeFiles/StandalonePlayer.dir/Platform/Linux/Standalone/main.cpp.o | Bindings/Contents/LUA/libPolycodeLua_d.a Core/Contents/libPolycore_d.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblua5.1.a ../../Release/Linux/Framework/Core/Dependencies/lib/libfreetype.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbisfile.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbis.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibogg.a ../../Release/Linux/Framework/Core/Dependencies/lib/libopenal.so ../../Release/Linux/Framework/Core/Dependencies/lib/libphysfs.a ../../Release/Linux/Framework/Core/Dependencies/lib/libpng15d.a ../../Release/Linux/Framework/Core/Dependencies/lib/libz.a /usr/lib64/libGLU.so /usr/lib64/libGL.so /usr/lib64/libSDL.so Modules/Bindings/2DPhysics/Physics2DLua_d.a Modules/Bindings/3DPhysics/Physics3DLua_d.a Modules/Bindings/UI/UILua_d.a Modules/Contents/2DPhysics/libPolycode2DPhysics_d.a Modules/Contents/3DPhysics/libPolycode3DPhysics_d.a Modules/Contents/UI/libPolycodeUI_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBox2D.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletMultiThreaded_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletSoftBody_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletDynamics_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletCollision_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libLinearMath_d.a Core/Contents/libPolycore_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBox2D_d.a ../../Release/Linux/Framework/Core/Dependencies/lib/libfreetype.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbisfile.a ../../Release/Linux/Framework/Core/Dependencies/lib/libopenal.so ../../Release/Linux/Framework/Core/Dependencies/lib/libphysfs.a ../../Release/Linux/Framework/Core/Dependencies/lib/libpng15d.a /usr/lib64/libGLU.so /usr/lib64/libGL.so || Core/Contents/libPolycore_d.a Bindings/Contents/LUA/libPolycodeLua_d.a Modules/Contents/2DPhysics/libPolycode2DPhysics_d.a Modules/Contents/3DPhysics/libPolycode3DPhysics_d.a Modules/Contents/UI/libPolycodeUI_d.a Modules/Bindings/2DPhysics/Physics2DLua_d.a Modules/Bindings/3DPhysics/Physics3DLua_d.a Modules/Bindings/UI/UILua_d.a
+ FLAGS = -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -g
+- LINK_FLAGS = -Wl,-O1,--sort-common,--as-needed,-z,relro
++ LINK_FLAGS = -lX11 -lxcb -Wl,-O1,--sort-common,--as-needed,-z,relro
+ LINK_LIBRARIES = -rdynamic -lrt -lpthread Bindings/Contents/LUA/libPolycodeLua_d.a Core/Contents/libPolycore_d.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblua5.1.a ../../Release/Linux/Framework/Core/Dependencies/lib/libfreetype.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbisfile.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbis.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibogg.a ../../Release/Linux/Framework/Core/Dependencies/lib/libopenal.so ../../Release/Linux/Framework/Core/Dependencies/lib/libphysfs.a ../../Release/Linux/Framework/Core/Dependencies/lib/libpng15d.a ../../Release/Linux/Framework/Core/Dependencies/lib/libz.a -lGLU -lGL -lSDL -ldl Modules/Bindings/2DPhysics/Physics2DLua_d.a Modules/Bindings/3DPhysics/Physics3DLua_d.a Modules/Bindings/UI/UILua_d.a Modules/Contents/2DPhysics/libPolycode2DPhysics_d.a Modules/Contents/3DPhysics/libPolycode3DPhysics_d.a Modules/Contents/UI/libPolycodeUI_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBox2D.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletMultiThreaded_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletSoftBody_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletDynamics_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletCollision_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libLinearMath_d.a Core/Contents/libPolycore_d.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBox2D_d.a ../../Release/Linux/Framework/Core/Dependencies/lib/libfreetype.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbisfile.a ../../Release/Linux/Framework/Core/Dependencies/lib/libopenal.so ../../Release/Linux/Framework/Core/Dependencies/lib/libphysfs.a ../../Release/Linux/Framework/Core/Dependencies/lib/libpng15d.a -lGLU -lGL -Wl,-rpath,/home/marcs/Arch/AUR/polycode/src/Polycode-master/Release/Linux/Framework/Core/Dependencies/lib:
+ OBJECT_DIR = Player/Contents/CMakeFiles/StandalonePlayer.dir
+ POST_BUILD = :
diff --git a/arch_link_fix_release.diff b/arch_link_fix_release.diff
new file mode 100644
index 000000000000..3943d8fbac0d
--- /dev/null
+++ b/arch_link_fix_release.diff
@@ -0,0 +1,29 @@
+--- build.ninja 2015-11-30 14:46:40.880324480 +0100
++++ build.ninja.arch 2015-11-30 14:48:35.452493135 +0100
+@@ -6,7 +6,7 @@
+
+ # =============================================================================
+ # Write statements declared in CMakeLists.txt:
+-#
++#
+ # Which is the root file.
+ # =============================================================================
+
+@@ -1365,7 +1365,7 @@
+
+ build Player/Contents/PolycodePlayer: CXX_EXECUTABLE_LINKER__PolycodePlayer Player/Contents/CMakeFiles/PolycodePlayer.dir/Source/PolycodePlayer.cpp.o Player/Contents/CMakeFiles/PolycodePlayer.dir/Source/PolycodeLinuxPlayer.cpp.o Player/Contents/CMakeFiles/PolycodePlayer.dir/Platform/Linux/main.cpp.o | Bindings/Contents/LUA/libPolycodeLua.a Core/Contents/libPolycore.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblua5.1.a ../../Release/Linux/Framework/Core/Dependencies/lib/libfreetype.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbisfile.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbis.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibogg.a ../../Release/Linux/Framework/Core/Dependencies/lib/libopenal.so ../../Release/Linux/Framework/Core/Dependencies/lib/libphysfs.a ../../Release/Linux/Framework/Core/Dependencies/lib/libpng.a ../../Release/Linux/Framework/Core/Dependencies/lib/libz.a /usr/lib64/libGLU.so /usr/lib64/libGL.so /usr/lib64/libSDL.so Modules/Bindings/2DPhysics/Physics2DLua.a Modules/Bindings/3DPhysics/Physics3DLua.a Modules/Bindings/UI/UILua.a Modules/Contents/2DPhysics/libPolycode2DPhysics.a Modules/Contents/3DPhysics/libPolycode3DPhysics.a Modules/Contents/UI/libPolycodeUI.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBox2D.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletMultiThreaded.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletSoftBody.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletDynamics.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletCollision.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libLinearMath.a Core/Contents/libPolycore.a ../../Release/Linux/Framework/Core/Dependencies/lib/libfreetype.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbisfile.a ../../Release/Linux/Framework/Core/Dependencies/lib/libopenal.so ../../Release/Linux/Framework/Core/Dependencies/lib/libphysfs.a ../../Release/Linux/Framework/Core/Dependencies/lib/libpng.a /usr/lib64/libGLU.so /usr/lib64/libGL.so || Core/Contents/libPolycore.a Bindings/Contents/LUA/libPolycodeLua.a Modules/Contents/2DPhysics/libPolycode2DPhysics.a Modules/Contents/3DPhysics/libPolycode3DPhysics.a Modules/Contents/UI/libPolycodeUI.a Modules/Bindings/2DPhysics/Physics2DLua.a Modules/Bindings/3DPhysics/Physics3DLua.a Modules/Bindings/UI/UILua.a
+ FLAGS = -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -O3 -DNDEBUG
+- LINK_FLAGS = -Wl,-O1,--sort-common,--as-needed,-z,relro
++ LINK_FLAGS = -lX11 -lxcb -Wl,-O1,--sort-common,--as-needed,-z,relro
+ LINK_LIBRARIES = -rdynamic -lrt -lpthread Bindings/Contents/LUA/libPolycodeLua.a Core/Contents/libPolycore.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblua5.1.a ../../Release/Linux/Framework/Core/Dependencies/lib/libfreetype.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbisfile.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbis.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibogg.a ../../Release/Linux/Framework/Core/Dependencies/lib/libopenal.so ../../Release/Linux/Framework/Core/Dependencies/lib/libphysfs.a ../../Release/Linux/Framework/Core/Dependencies/lib/libpng.a ../../Release/Linux/Framework/Core/Dependencies/lib/libz.a -lGLU -lGL -lSDL -ldl Modules/Bindings/2DPhysics/Physics2DLua.a Modules/Bindings/3DPhysics/Physics3DLua.a Modules/Bindings/UI/UILua.a Modules/Contents/2DPhysics/libPolycode2DPhysics.a Modules/Contents/3DPhysics/libPolycode3DPhysics.a Modules/Contents/UI/libPolycodeUI.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBox2D.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletMultiThreaded.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletSoftBody.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletDynamics.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletCollision.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libLinearMath.a Core/Contents/libPolycore.a ../../Release/Linux/Framework/Core/Dependencies/lib/libfreetype.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbisfile.a ../../Release/Linux/Framework/Core/Dependencies/lib/libopenal.so ../../Release/Linux/Framework/Core/Dependencies/lib/libphysfs.a ../../Release/Linux/Framework/Core/Dependencies/lib/libpng.a -lGLU -lGL -Wl,-rpath,/home/marcs/Arch/AUR/polycode/src/Polycode-master/Release/Linux/Framework/Core/Dependencies/lib:
+ OBJECT_DIR = Player/Contents/CMakeFiles/PolycodePlayer.dir
+ POST_BUILD = :
+@@ -1411,7 +1411,7 @@
+
+ build Player/Contents/StandalonePlayer: CXX_EXECUTABLE_LINKER__StandalonePlayer Player/Contents/CMakeFiles/StandalonePlayer.dir/Source/PolycodePlayer.cpp.o Player/Contents/CMakeFiles/StandalonePlayer.dir/Source/PolycodeLinuxPlayer.cpp.o Player/Contents/CMakeFiles/StandalonePlayer.dir/Platform/Linux/Standalone/main.cpp.o | Bindings/Contents/LUA/libPolycodeLua.a Core/Contents/libPolycore.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblua5.1.a ../../Release/Linux/Framework/Core/Dependencies/lib/libfreetype.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbisfile.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbis.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibogg.a ../../Release/Linux/Framework/Core/Dependencies/lib/libopenal.so ../../Release/Linux/Framework/Core/Dependencies/lib/libphysfs.a ../../Release/Linux/Framework/Core/Dependencies/lib/libpng.a ../../Release/Linux/Framework/Core/Dependencies/lib/libz.a /usr/lib64/libGLU.so /usr/lib64/libGL.so /usr/lib64/libSDL.so Modules/Bindings/2DPhysics/Physics2DLua.a Modules/Bindings/3DPhysics/Physics3DLua.a Modules/Bindings/UI/UILua.a Modules/Contents/2DPhysics/libPolycode2DPhysics.a Modules/Contents/3DPhysics/libPolycode3DPhysics.a Modules/Contents/UI/libPolycodeUI.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBox2D.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletMultiThreaded.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletSoftBody.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletDynamics.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletCollision.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libLinearMath.a Core/Contents/libPolycore.a ../../Release/Linux/Framework/Core/Dependencies/lib/libfreetype.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbisfile.a ../../Release/Linux/Framework/Core/Dependencies/lib/libopenal.so ../../Release/Linux/Framework/Core/Dependencies/lib/libphysfs.a ../../Release/Linux/Framework/Core/Dependencies/lib/libpng.a /usr/lib64/libGLU.so /usr/lib64/libGL.so || Core/Contents/libPolycore.a Bindings/Contents/LUA/libPolycodeLua.a Modules/Contents/2DPhysics/libPolycode2DPhysics.a Modules/Contents/3DPhysics/libPolycode3DPhysics.a Modules/Contents/UI/libPolycodeUI.a Modules/Bindings/2DPhysics/Physics2DLua.a Modules/Bindings/3DPhysics/Physics3DLua.a Modules/Bindings/UI/UILua.a
+ FLAGS = -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -O3 -DNDEBUG
+- LINK_FLAGS = -Wl,-O1,--sort-common,--as-needed,-z,relro
++ LINK_FLAGS = -lX11 -lxcb -Wl,-O1,--sort-common,--as-needed,-z,relro
+ LINK_LIBRARIES = -rdynamic -lrt -lpthread Bindings/Contents/LUA/libPolycodeLua.a Core/Contents/libPolycore.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblua5.1.a ../../Release/Linux/Framework/Core/Dependencies/lib/libfreetype.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbisfile.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbis.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibogg.a ../../Release/Linux/Framework/Core/Dependencies/lib/libopenal.so ../../Release/Linux/Framework/Core/Dependencies/lib/libphysfs.a ../../Release/Linux/Framework/Core/Dependencies/lib/libpng.a ../../Release/Linux/Framework/Core/Dependencies/lib/libz.a -lGLU -lGL -lSDL -ldl Modules/Bindings/2DPhysics/Physics2DLua.a Modules/Bindings/3DPhysics/Physics3DLua.a Modules/Bindings/UI/UILua.a Modules/Contents/2DPhysics/libPolycode2DPhysics.a Modules/Contents/3DPhysics/libPolycode3DPhysics.a Modules/Contents/UI/libPolycodeUI.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBox2D.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletMultiThreaded.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletSoftBody.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletDynamics.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libBulletCollision.a ../../Release/Linux/Framework/Modules/Dependencies/lib/libLinearMath.a Core/Contents/libPolycore.a ../../Release/Linux/Framework/Core/Dependencies/lib/libfreetype.a ../../Release/Linux/Framework/Core/Dependencies/lib/liblibvorbisfile.a ../../Release/Linux/Framework/Core/Dependencies/lib/libopenal.so ../../Release/Linux/Framework/Core/Dependencies/lib/libphysfs.a ../../Release/Linux/Framework/Core/Dependencies/lib/libpng.a -lGLU -lGL -Wl,-rpath,/home/marcs/Arch/AUR/polycode/src/Polycode-master/Release/Linux/Framework/Core/Dependencies/lib:
+ OBJECT_DIR = Player/Contents/CMakeFiles/StandalonePlayer.dir
+ POST_BUILD = :
diff --git a/polycode.desktop b/polycode.desktop
new file mode 100644
index 000000000000..9fee629a83ad
--- /dev/null
+++ b/polycode.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Polycode
+Comment=The IDE bundled with the Polycode framework.
+Exec=/opt/polycode/IDE/Polycode
+Path=/opt/polycode/IDE/
+Icon=polycode
+Terminal=false
+Categories=Development;IDE;
+StartupNotify=true
+MimeType=application/x-polycode;application/x-polycode-workspace;