summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis Kasak2020-09-11 15:26:15 +0200
committerDenis Kasak2020-09-11 15:26:15 +0200
commit016fdb84219fd16edf6ca05b1d2dacb5331c284e (patch)
tree95ecf923d74dabfdf41e6c65d98ca2cc6fbedb7c
downloadaur-016fdb84219fd16edf6ca05b1d2dacb5331c284e.tar.gz
Initial commit.
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD27
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..970e2beddb3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = polyfile
+ pkgdesc = A utility to identify and map the semantic structure of files, including polyglots, chimeras, and schizophrenic files.
+ pkgver = 0.1.6
+ pkgrel = 1
+ url = https://github.com/trailofbits/polyfile
+ arch = any
+ license = LGPLv3
+ makedepends = python-setuptools
+ depends = python
+ depends = python-graphviz
+ depends = python-intervaltree
+ depends = python-jinja
+ depends = python-kaitaistruct>=0.7
+ depends = python-networkx
+ depends = python-pillow>=5.0.0
+ depends = python-pyaml>=3.13
+ source = https://github.com/trailofbits/polyfile/archive/v0.1.6.tar.gz
+ sha256sums = 51eccc0c9149501fa597863667c145d34f1d28225614cef60aa1cecab28ed653
+
+pkgname = polyfile
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72a3ed3fe6e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1aca954b6a5b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Denis Kasak <dkasak AT termina DOT org DOT uk>
+
+pkgname=polyfile
+pkgver=0.1.6
+pkgrel=1
+pkgdesc="A utility to identify and map the semantic structure of files, including polyglots, chimeras, and schizophrenic files."
+arch=('any')
+url=https://github.com/trailofbits/polyfile
+license=('LGPLv3')
+depends=('python' 'python-graphviz' 'python-intervaltree' 'python-jinja'
+ 'python-kaitaistruct>=0.7' 'python-networkx' 'python-pillow>=5.0.0'
+ 'python-pyaml>=3.13')
+makedepends=('python-setuptools')
+source=(https://github.com/trailofbits/${pkgname}/archive/v${pkgver}.tar.gz)
+sha256sums=('51eccc0c9149501fa597863667c145d34f1d28225614cef60aa1cecab28ed653')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+# vim:ts=4:sw=4:et: