summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-07-04 22:55:01 +0200
committerFabioLolix2022-07-04 22:55:01 +0200
commit8732a38224dda59f62742735deedcaf634602cb8 (patch)
treecdd428f67e6a33bc013eecbd80ba53f6e41a1ea8
parent595ac4e805b5240115235323240fab804e88a341 (diff)
downloadaur-8732a38224dda59f62742735deedcaf634602cb8.tar.gz
v0.4.2
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
2 files changed, 36 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1114ba395d7c..1aa34f9da466 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,27 @@
pkgbase = polyfile
pkgdesc = A utility to identify and map the semantic structure of files, including polyglots, chimeras, and schizophrenic files.
- pkgver = 0.1.7
+ pkgver = 0.4.2
pkgrel = 1
url = https://github.com/trailofbits/polyfile
arch = any
- license = LGPLv3
+ license = LGPL3
+ makedepends = git
makedepends = python-setuptools
depends = python
depends = python-graphviz
depends = python-intervaltree
depends = python-jinja
- depends = python-kaitaistruct>=0.7
+ depends = python-kaitaistruct
depends = python-networkx
- depends = python-pillow>=5.0.0
- depends = python-yaml>=3.13
- source = https://github.com/trailofbits/polyfile/archive/v0.1.7.tar.gz
- sha256sums = 201e329a0762165c54e95758c1c9e26a70a68d821d464b5801568c2a0c3c14d8
+ depends = python-pdfminer
+ depends = python-pillow
+ depends = python-yaml
+ depends = python-cint-git
+ source = git+https://github.com/trailofbits/polyfile.git#tag=v0.4.2
+ source = git+https://github.com/kaitai-io/kaitai_struct_formats.git
+ source = git+https://github.com/file/file.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = polyfile
-
diff --git a/PKGBUILD b/PKGBUILD
index b0f22799bf5d..385ed1b8ee2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,36 @@
# Maintainer: Denis Kasak <dkasak AT termina DOT org DOT uk>
pkgname=polyfile
-pkgver=0.1.7
+pkgver=0.4.2
pkgrel=1
pkgdesc="A utility to identify and map the semantic structure of files, including polyglots, chimeras, and schizophrenic files."
-arch=('any')
+arch=(any)
url=https://github.com/trailofbits/polyfile
-license=('LGPLv3')
-depends=('python' 'python-graphviz' 'python-intervaltree' 'python-jinja'
- 'python-kaitaistruct>=0.7' 'python-networkx' 'python-pillow>=5.0.0'
- 'python-yaml>=3.13')
-makedepends=('python-setuptools')
-source=(https://github.com/trailofbits/${pkgname}/archive/v${pkgver}.tar.gz)
-sha256sums=('201e329a0762165c54e95758c1c9e26a70a68d821d464b5801568c2a0c3c14d8')
+license=(LGPL3)
+depends=(python python-graphviz python-intervaltree python-jinja
+ python-kaitaistruct python-networkx python-pdfminer
+ python-pillow python-yaml python-cint-git)
+makedepends=(git python-setuptools)
+source=("git+https://github.com/trailofbits/polyfile.git#tag=v${pkgver}"
+ "git+https://github.com/kaitai-io/kaitai_struct_formats.git"
+ "git+https://github.com/file/file.git")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+prepare() {
+ cd "$srcdir/polyfile"
+ git submodule init
+ git config submodule.kaitai_struct_formats.url "$srcdir/kaitai_struct_formats"
+ git config submodule.file.url "$srcdir/file"
+ git submodule update
+}
build() {
- cd "$srcdir/$pkgname-$pkgver/"
+ cd "$srcdir/polyfile"
python setup.py build
}
package() {
- cd "$srcdir/$pkgname-$pkgver/"
+ cd "$srcdir/polyfile"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
-
-# vim:ts=4:sw=4:et: