summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2019-08-07 20:37:42 -0700
committerDonald Webster2019-08-07 21:49:32 -0700
commitcdc8a1a0310e14f3ec1a4f92009f288c6c182885 (patch)
tree81f1a29a2addeb53bd83e56b1e76670deee0e516
downloadaur-cdc8a1a0310e14f3ec1a4f92009f288c6c182885.tar.gz
Initial version of polyglot package.
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD38
-rw-r--r--polyglot.service14
-rw-r--r--polyglot.sysusers1
-rw-r--r--polyglot.tmpfiles2
6 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87156f847b15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = polyglot
+ pkgdesc = A python library built which abstracts out all ISY 5.0 Node Server APIs.
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = https://github.com/UniversalDevicesInc/polyglot-v2
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ depends = python
+ depends = mongodb
+ depends = curl
+ options = !strip
+ source = polyglot.service
+ source = polyglot.tmpfiles
+ source = polyglot.sysusers
+ sha256sums = 584e9fba9d818c1301ac0364f9a6bd9c4061a21ae691c47ee0fe989d4ad897c4
+ sha256sums = b0fe8bc8f8eb63c267f81b55101789ed18e908c9ea43fc8299d05e879605e26c
+ sha256sums = 728783fb5152baf655131ad1427d1c2524a6f7d76a3664c070c4f0f5df443728
+ source_x86_64 = polyglot-2.2.1-1.x86_64.tar.gz::https://s3.amazonaws.com/polyglotv2/binaries/polyglot-v2-linux-x64.tar.gz
+ sha256sums_x86_64 = ba8d6f6e4089c7ccd6487c5b2325a672524c3b5e6b4a5ce877a4c96a9b519a1f
+ source_armv7h = polyglot-2.2.1-1.armv7h.tar.gz::https://s3.amazonaws.com/polyglotv2/binaries/polyglot-v2-linux-armv7.tar.gz
+ sha256sums_armv7h = 959307719a4103bb1058808799f18b011e35613d0c31e877fa41a683eaaeaab3
+ source_aarch64 = polyglot-2.2.1-1.aarch64.tar.gz::https://s3.amazonaws.com/polyglotv2/binaries/polyglot-v2-linux-armv7.tar.gz
+ sha256sums_aarch64 = 959307719a4103bb1058808799f18b011e35613d0c31e877fa41a683eaaeaab3
+
+pkgname = polyglot
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8de5dbf385fd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/*.gz
+/*.xz
+/src/
+/pkg/
+/Polyglot/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..559902e14586
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Donald Webster <fryfrog@gmail.com>
+
+pkgname=polyglot
+pkgver=2.2.1
+pkgrel=1
+pkgdesc='A python library built which abstracts out all ISY 5.0 Node Server APIs.'
+arch=('x86_64' 'armv7h' 'aarch64')
+url="https://github.com/UniversalDevicesInc/polyglot-v2"
+license=('MIT')
+depends=('python'
+ 'mongodb'
+ 'curl')
+
+options=('!strip')
+
+source_x86_64=("${pkgname}-${pkgver}-${pkgrel}.x86_64.tar.gz::https://s3.amazonaws.com/polyglotv2/binaries/polyglot-v2-linux-x64.tar.gz")
+source_armv7h=("${pkgname}-${pkgver}-${pkgrel}.armv7h.tar.gz::https://s3.amazonaws.com/polyglotv2/binaries/polyglot-v2-linux-armv7.tar.gz")
+source_aarch64=("${pkgname}-${pkgver}-${pkgrel}.aarch64.tar.gz::https://s3.amazonaws.com/polyglotv2/binaries/polyglot-v2-linux-armv7.tar.gz")
+
+source=('polyglot.service'
+ 'polyglot.tmpfiles'
+ 'polyglot.sysusers')
+
+sha256sums=('584e9fba9d818c1301ac0364f9a6bd9c4061a21ae691c47ee0fe989d4ad897c4'
+ 'b0fe8bc8f8eb63c267f81b55101789ed18e908c9ea43fc8299d05e879605e26c'
+ '728783fb5152baf655131ad1427d1c2524a6f7d76a3664c070c4f0f5df443728')
+sha256sums_x86_64=('ba8d6f6e4089c7ccd6487c5b2325a672524c3b5e6b4a5ce877a4c96a9b519a1f')
+sha256sums_armv7h=('959307719a4103bb1058808799f18b011e35613d0c31e877fa41a683eaaeaab3')
+sha256sums_aarch64=('959307719a4103bb1058808799f18b011e35613d0c31e877fa41a683eaaeaab3')
+
+
+package() {
+ install -D -m 755 "${srcdir}/polyglot-v2-linux-x64" "${pkgdir}/usr/bin/polyglot"
+
+ install -D -m 644 "${srcdir}/polyglot.service" "${pkgdir}/usr/lib/systemd/system/polyglot.service"
+ install -D -m 644 "${srcdir}/polyglot.sysusers" "${pkgdir}/usr/lib/sysusers.d/polyglot.conf"
+ install -D -m 644 "${srcdir}/polyglot.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/polyglot.conf"
+}
diff --git a/polyglot.service b/polyglot.service
new file mode 100644
index 000000000000..9555ab4ff1cb
--- /dev/null
+++ b/polyglot.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=polyglot
+After=network-online.target
+
+[Service]
+Type=simple
+WorkingDirectory=/var/lib/polyglot
+ExecStart=/usr/bin/polyglot
+Restart=always
+User=polyglot
+Group=polyglot
+
+[Install]
+WantedBy=multi-user.target
diff --git a/polyglot.sysusers b/polyglot.sysusers
new file mode 100644
index 000000000000..0155a03ab8d7
--- /dev/null
+++ b/polyglot.sysusers
@@ -0,0 +1 @@
+u polyglot - "polyglot" /var/lib/polyglot
diff --git a/polyglot.tmpfiles b/polyglot.tmpfiles
new file mode 100644
index 000000000000..e54ec3a60e29
--- /dev/null
+++ b/polyglot.tmpfiles
@@ -0,0 +1,2 @@
+d /var/lib/polyglot 0755 polyglot polyglot
+Z /var/lib/polyglot - polyglot polyglot