summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerry2023-09-15 00:16:05 +0800
committerJerry2023-09-15 00:17:19 +0800
commit414d323023fa280137b1081cad035ff5a6f6c127 (patch)
tree97450c57a25c557b1853444b8a991c63198a07a4
parentf06432e03ad5c4396ae63e132596e8b0c340967c (diff)
downloadaur-polyglot-winboard-git.tar.gz
change conflict
polyglot is such a generic term it might conflict with more packages in the future, however the executable name is kept original so that might still be useless.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70777c8ba825..8ccee1a69830 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = polyglot-winboard-git
pkgdesc = UCI/USI/UCCI to XBoard adapter (WinBoard fork)
pkgver = r44.5904a29
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = http://hgm.nubati.net/cgi-bin/gitweb.cgi?p=polyglot.git;a=summary
arch = i686
arch = x86_64
license = GPL2
makedepends = git
- depends = glibc
- provides = polyglot=r44.5904a29
- conflicts = polyglot
- replaces = polyglot
+ provides = polyglot-winboard=r44.5904a29
+ conflicts = polyglot-winboard
source = git+http://hgm.nubati.net/git/polyglot.git
md5sums = SKIP
pkgname = polyglot-winboard-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 2f5ed390c434..87cf7c143b68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,36 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
-_pkgname=polyglot
+_srcname=polyglot
+_pkgname=polyglot-winboard
pkgname=polyglot-winboard-git
pkgver=r44.5904a29
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc="UCI/USI/UCCI to XBoard adapter (WinBoard fork)"
arch=('i686' 'x86_64')
url="http://hgm.nubati.net/cgi-bin/gitweb.cgi?p=polyglot.git;a=summary"
license=('GPL2')
-depends=('glibc')
makedepends=('git')
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
-replaces=("${_pkgname}")
-source=("git+http://hgm.nubati.net/git/${_pkgname}.git")
+source=("git+http://hgm.nubati.net/git/${_srcname}.git")
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_srcname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_srcname}"
./configure --prefix=/usr
make CFLAGS="$CFLAGS -fcommon"
}
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_srcname}"
make DESTDIR="${pkgdir}" install
}