summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2020-08-02 21:29:15 +0100
committerMilk Brewster2020-08-02 21:29:15 +0100
commitdad25f92059e47542ebfceb6a4f7f5e3af65e9d6 (patch)
tree54b65127236ae60e12940ff34fa2f8c79487ae36
downloadaur-dad25f92059e47542ebfceb6a4f7f5e3af65e9d6.tar.gz
initial move
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD49
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42b3b2ae68d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = polylenticular.lv2-git
+ pkgdesc = Ports of VCV Rack modules to LV2
+ pkgver = r81.89fc961
+ pkgrel = 1
+ url = https://github.com/polyeffects/lenticular_lv2
+ arch = x86_64
+ license = GPL
+ source = polylenticular.lv2-git::git+https://github.com/polyeffects/lenticular_lv2
+ md5sums = SKIP
+
+pkgname = polylenticular.lv2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd178fe4fdf7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Milkii Brewster <milkii on Freenode IRC>
+maintaner="Milkii Brewster <milkii on Freenode IRC>"
+pkgname=polylenticular.lv2-git
+pkgdesc="Ports of VCV Rack modules to LV2"
+pkgver=r81.89fc961
+pkgrel=1
+epoch=
+arch=(x86_64)
+url="https://github.com/polyeffects/lenticular_lv2"
+license=(GPL)
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(polylenticular.lv2-git::git+https://github.com/polyeffects/lenticular_lv2)
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "$pkgname"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$pkgname"
+ # ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}