summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2022-10-15 20:05:31 +0200
committerSefa Eyeoglu2022-10-15 20:05:31 +0200
commit65f8670445b0b400ead663a654ca3b419d2b0edb (patch)
treefa21d4e255746efeab619ef4356961a1a3e6f9ea
parentaa1a10d531120493c3cedbe7872056b325080753 (diff)
downloadaur-65f8670445b0b400ead663a654ca3b419d2b0edb.tar.gz
upgpkg: polymc-git 1.4.0.r348.gc089f9b5-2
add ghc-filesystem Signed-off-by: Sefa Eyeoglu <contact@scrumplex.net>
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c32948b2d33c..20a3bab92ce3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = polymc-git
pkgdesc = Minecraft launcher with ability to manage multiple instances.
- pkgver = 1.4.0.r301.gc97a47dc
- pkgrel = 3
+ pkgver = 1.4.0.r348.gc089f9b5
+ pkgrel = 2
url = https://github.com/PolyMC/PolyMC
arch = i686
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = polymc-git
makedepends = java-environment
makedepends = scdoc
makedepends = tomlplusplus
+ makedepends = ghc-filesystem
depends = java-runtime
depends = libgl
depends = qt6-base
diff --git a/PKGBUILD b/PKGBUILD
index b06fe1f0d8c2..8caef53bfe59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
_pkgname=polymc
pkgname=${_pkgname}-git
-pkgver=1.4.0.r301.gc97a47dc
-pkgrel=3
+pkgver=1.4.0.r348.gc089f9b5
+pkgrel=2
pkgdesc="Minecraft launcher with ability to manage multiple instances."
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/PolyMC/PolyMC"
@@ -15,7 +15,7 @@ license=('GPL3')
depends=('java-runtime' 'libgl' 'qt6-base' 'qt6-5compat' 'qt6-svg' 'qt6-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt6')
provides=('polymc')
conflicts=('polymc')
-makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc' 'tomlplusplus')
+makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc' 'tomlplusplus' 'ghc-filesystem')
optdepends=('glfw: to use system GLFW libraries'
'openal: to use system OpenAL libraries'
'visualvm: Profiling support'
@@ -36,9 +36,10 @@ pkgver() {
prepare() {
cd "PolyMC"
git submodule init
- git config submodule.libraries/libnbtplusplus.url "${srcdir}/libnbtplusplus"
+ git config submodule.depends/libnbtplusplus.url "${srcdir}/libnbtplusplus"
git config submodule.libraries/quazip.active false
git config submodule.libraries/tomlplusplus.active false
+ git config submodule.libraries/filesystem.active false
git submodule update
}