summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2022-09-30 23:49:27 +0200
committerSefa Eyeoglu2022-09-30 23:49:27 +0200
commit99bca83e1aefa743bdf7d58f8f63881773a70beb (patch)
treef75c6cc98f7a8deb5fcd88d6244e9885efaff19e
parentef9e99f55c9a3cc183459f10d7b9931c48362f11 (diff)
downloadaur-99bca83e1aefa743bdf7d58f8f63881773a70beb.tar.gz
upgpkg: polymc-git 1.4.0.r301.gc97a47dc-2
add libs Signed-off-by: Sefa Eyeoglu <contact@scrumplex.net>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43df91eb4a29..0b7dcad95af2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = polymc-git
pkgdesc = Minecraft launcher with ability to manage multiple instances.
- pkgver = 1.4.0.r223.g30abb653
- pkgrel = 1
+ pkgver = 1.4.0.r301.gc97a47dc
+ pkgrel = 2
url = https://github.com/PolyMC/PolyMC
arch = i686
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = polymc-git
makedepends = git
makedepends = java-environment
makedepends = scdoc
+ makedepends = tomlplusplus
depends = java-runtime
depends = libgl
depends = qt6-base
@@ -19,6 +20,7 @@ pkgbase = polymc-git
depends = qt6-imageformats
depends = zlib
depends = hicolor-icon-theme
+ depends = quazip-qt6
optdepends = glfw: to use system GLFW libraries
optdepends = openal: to use system OpenAL libraries
optdepends = visualvm: Profiling support
@@ -28,8 +30,6 @@ pkgbase = polymc-git
options = debug
source = git+https://github.com/PolyMC/PolyMC
source = git+https://github.com/PolyMC/libnbtplusplus
- source = git+https://github.com/stachenov/quazip
- sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index be2762b34b69..3bb1c9a18dd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,16 +6,16 @@
_pkgname=polymc
pkgname=${_pkgname}-git
-pkgver=1.4.0.r223.g30abb653
-pkgrel=1
+pkgver=1.4.0.r301.gc97a47dc
+pkgrel=2
pkgdesc="Minecraft launcher with ability to manage multiple instances."
arch=('i686' 'x86_64')
url="https://github.com/PolyMC/PolyMC"
license=('GPL3')
-depends=('java-runtime' 'libgl' 'qt6-base' 'qt6-5compat' 'qt6-svg' 'qt6-imageformats' 'zlib' 'hicolor-icon-theme')
+depends=('java-runtime' 'libgl' 'qt6-base' 'qt6-5compat' 'qt6-svg' 'qt6-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt6')
provides=('polymc')
conflicts=('polymc')
-makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc')
+makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc' 'tomlplusplus')
optdepends=('glfw: to use system GLFW libraries'
'openal: to use system OpenAL libraries'
'visualvm: Profiling support'
@@ -23,11 +23,9 @@ optdepends=('glfw: to use system GLFW libraries'
)
options=(debug)
source=("git+https://github.com/PolyMC/PolyMC"
- "git+https://github.com/PolyMC/libnbtplusplus"
- "git+https://github.com/stachenov/quazip")
+ "git+https://github.com/PolyMC/libnbtplusplus")
sha256sums=('SKIP'
- 'SKIP'
'SKIP')
pkgver() {
@@ -38,8 +36,9 @@ pkgver() {
prepare() {
cd "PolyMC"
git submodule init
- git config submodule.libnbtplusplus.url "${srcdir}/libnbtplusplus"
- git config submodule.quazip.url "${srcdir}/quazip"
+ git config submodule.libraries/libnbtplusplus.url "${srcdir}/libnbtplusplus"
+ git config submodule.libraries/quazip.active false
+ git config submodule.libraries/tomlplusplus.active false
git submodule update
}