summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaydax2023-02-04 12:44:07 -0500
committerKaydax2023-02-04 12:44:07 -0500
commit14d5c7e0d6b2a7173ab5247a9190c75a4ee51999 (patch)
tree97e6fac790d2375804ff9c0d03b6fe30830353fd
parent8b4e3f0b7a71f3f70be1fa7422be6591aa4bda08 (diff)
downloadaur-14d5c7e0d6b2a7173ab5247a9190c75a4ee51999.tar.gz
Add missing dep, remove broken check
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 4 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67375028320c..fd029fc50d9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = polymc-qt5
pkgdesc = Minecraft launcher with ability to manage multiple instances.
pkgver = 5.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/PolyMC/PolyMC
arch = i686
arch = x86_64
@@ -19,6 +19,7 @@ pkgbase = polymc-qt5
depends = zlib
depends = hicolor-icon-theme
depends = quazip-qt5
+ depends = qt5-charts
optdepends = glfw: to use system GLFW libraries
optdepends = openal: to use system OpenAL libraries
optdepends = visualvm: Profiling support
diff --git a/PKGBUILD b/PKGBUILD
index 2308483ec297..b76c35b99e6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,12 @@
pkgname=polymc-qt5
pkgver=5.0
-pkgrel=2
+pkgrel=3
pkgdesc="Minecraft launcher with ability to manage multiple instances."
arch=('i686' 'x86_64')
url="https://github.com/PolyMC/PolyMC"
license=('GPL3')
-depends=('java-runtime' 'libgl' 'qt5-base' 'qt5-svg' 'qt5-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt5')
+depends=('java-runtime' 'libgl' 'qt5-base' 'qt5-svg' 'qt5-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt5' 'qt5-charts')
provides=('polymc')
conflicts=('polymc')
makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc')
@@ -35,11 +35,6 @@ build() {
cmake --build build
}
-check() {
- cd "build"
- ctest .
-}
-
package() {
cd "build"
DESTDIR="$pkgdir" cmake --install .