summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaydax2022-12-27 17:56:23 -0500
committerKaydax2022-12-27 17:56:23 -0500
commit8434a62fcbc62684113ce93a73c65fdd568fca7b (patch)
tree2ba07e08a7f88b737eade701b4cf93f665fb3672
parentcf3c354a6bd5b9bb3d16ab3afdf6c5a92c3b10e6 (diff)
downloadaur-8434a62fcbc62684113ce93a73c65fdd568fca7b.tar.gz
Add qt5-charts dep, fix issue with git command
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD8
3 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24ecaf30e938..0316f3af445c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = polymc-qt5-git
pkgdesc = Minecraft launcher with ability to manage multiple instances.
- pkgver = 1.4.0.r348.gc089f9b5
- pkgrel = 2
+ pkgver = 1.4.0.r390.g7839bd0e
+ pkgrel = 1
url = https://github.com/PolyMC/PolyMC
arch = i686
arch = x86_64
@@ -22,6 +22,7 @@ pkgbase = polymc-qt5-git
depends = zlib
depends = hicolor-icon-theme
depends = quazip-qt5
+ depends = qt5-charts
optdepends = glfw: to use system GLFW libraries
optdepends = openal: to use system OpenAL libraries
optdepends = visualvm: Profiling support
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ef41849d7cd0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+PolyMC/
+libnbtplusplus/
+quazip/
+src/
+pkg/
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index b069b8ce25b6..013995904403 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@
_pkgname=polymc
pkgname=${_pkgname}-qt5-git
-pkgver=1.4.0.r348.gc089f9b5
-pkgrel=2
+pkgver=1.4.0.r390.g7839bd0e
+pkgrel=1
pkgdesc="Minecraft launcher with ability to manage multiple instances."
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/PolyMC/PolyMC"
license=('GPL3')
-depends=('java-runtime' 'libgl' 'qt5-base' 'qt5-svg' 'qt5-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt5')
+depends=('java-runtime' 'libgl' 'qt5-base' 'qt5-svg' 'qt5-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt5' 'qt5-charts')
provides=('polymc' 'polymc-qt5')
conflicts=('polymc' 'polymc-qt5')
makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc' 'tomlplusplus' 'ghc-filesystem')
@@ -39,7 +39,7 @@ prepare() {
git config submodule.libraries/quazip.active false
git config submodule.libraries/tomlplusplus.active false
git config submodule.libraries/filesystem.active false
- git submodule update
+ git -c protocol.file.allow=always submodule update
}
build() {