summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2022-10-15 20:07:46 +0200
committerSefa Eyeoglu2022-10-15 20:07:46 +0200
commitcf3c354a6bd5b9bb3d16ab3afdf6c5a92c3b10e6 (patch)
tree7c5419e9b83d2cd40b8be3f9a4628425ab863f91
parent6f6d6cf2734666e3e9894764aa67b2d66e820188 (diff)
downloadaur-cf3c354a6bd5b9bb3d16ab3afdf6c5a92c3b10e6.tar.gz
upgpkg: polymc-qt5-git 1.4.0.r348.gc089f9b5-2
add ghc-filesystem Signed-off-by: Sefa Eyeoglu <contact@scrumplex.net>
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58c45670b149..24ecaf30e938 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = polymc-qt5-git
pkgdesc = Minecraft launcher with ability to manage multiple instances.
- pkgver = 1.4.0.r301.gc97a47dc
- pkgrel = 3
+ pkgver = 1.4.0.r348.gc089f9b5
+ pkgrel = 2
url = https://github.com/PolyMC/PolyMC
arch = i686
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = polymc-qt5-git
makedepends = java-environment
makedepends = scdoc
makedepends = tomlplusplus
+ makedepends = ghc-filesystem
depends = java-runtime
depends = libgl
depends = qt5-base
diff --git a/PKGBUILD b/PKGBUILD
index d266ff113494..b069b8ce25b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
_pkgname=polymc
pkgname=${_pkgname}-qt5-git
-pkgver=1.4.0.r301.gc97a47dc
-pkgrel=3
+pkgver=1.4.0.r348.gc089f9b5
+pkgrel=2
pkgdesc="Minecraft launcher with ability to manage multiple instances."
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/PolyMC/PolyMC"
@@ -15,7 +15,7 @@ license=('GPL3')
depends=('java-runtime' 'libgl' 'qt5-base' 'qt5-svg' 'qt5-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt5')
provides=('polymc' 'polymc-qt5')
conflicts=('polymc' 'polymc-qt5')
-makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc' 'tomlplusplus')
+makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc' 'tomlplusplus' 'ghc-filesystem')
optdepends=('glfw: to use system GLFW libraries'
'openal: to use system OpenAL libraries'
'visualvm: Profiling support'
@@ -35,9 +35,10 @@ pkgver() {
prepare() {
cd "PolyMC"
git submodule init
- git config submodule.libraries/libnbtplusplus.url "${srcdir}/libnbtplusplus"
+ git config submodule.depends/libnbtplusplus.url "${srcdir}/libnbtplusplus"
git config submodule.libraries/quazip.active false
git config submodule.libraries/tomlplusplus.active false
+ git config submodule.libraries/filesystem.active false
git submodule update
}