summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2022-07-11 09:59:23 +0200
committerSefa Eyeoglu2022-07-11 09:59:24 +0200
commitf2628650bc9a7e2c7c5fcfdf8b5b3104bca694f0 (patch)
treed2353e2ee5d9149a5ebf7d135f72405df6555a85
downloadaur-f2628650bc9a7e2c7c5fcfdf8b5b3104bca694f0.tar.gz
initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD66
2 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d247f6d5a9f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = polymc-qt5-git
+ pkgdesc = Minecraft launcher with ability to manage multiple instances.
+ pkgver = 1.3.1.r295.gac8ee9f9
+ pkgrel = 1
+ url = https://github.com/PolyMC/PolyMC
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ makedepends = git
+ makedepends = java-environment
+ depends = java-runtime
+ depends = libgl
+ depends = qt5-base
+ depends = qt5-svg
+ depends = qt5-imageformats
+ depends = zlib
+ depends = hicolor-icon-theme
+ optdepends = glfw: to use system GLFW libraries
+ optdepends = openal: to use system OpenAL libraries
+ optdepends = visualvm: Profiling support
+ optdepends = xorg-xrandr: for older minecraft versions
+ provides = polymc
+ provides = polymc-qt5
+ conflicts = polymc
+ conflicts = polymc-qt5
+ source = git+https://github.com/PolyMC/PolyMC
+ source = git+https://github.com/PolyMC/libnbtplusplus
+ source = git+https://github.com/stachenov/quazip
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = polymc-qt5-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73fd1f32b28b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+# Maintainer: Lenny McLennington <lennymclennington@protonmail.com>
+# Contributor: Elijah Gregg <lovetocode999 at tilde dot team>
+# Contributor: Miko <mikoxyzzz@gmail.com>
+# Contributor: Cheru Berhanu <aur attt cheru doot dev>
+
+_pkgname=polymc
+pkgname=${_pkgname}-qt5-git
+pkgver=1.3.1.r295.gac8ee9f9
+pkgrel=1
+pkgdesc="Minecraft launcher with ability to manage multiple instances."
+arch=('i686' 'x86_64')
+url="https://github.com/PolyMC/PolyMC"
+license=('GPL3')
+depends=('java-runtime' 'libgl' 'qt5-base' 'qt5-svg' 'qt5-imageformats' 'zlib' 'hicolor-icon-theme')
+provides=('polymc' 'polymc-qt5')
+conflicts=('polymc' 'polymc-qt5')
+makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment')
+optdepends=('glfw: to use system GLFW libraries'
+ 'openal: to use system OpenAL libraries'
+ 'visualvm: Profiling support'
+ 'xorg-xrandr: for older minecraft versions'
+)
+source=("git+https://github.com/PolyMC/PolyMC"
+ "git+https://github.com/PolyMC/libnbtplusplus"
+ "git+https://github.com/stachenov/quazip")
+
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd PolyMC
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/PolyMC"
+ git submodule init
+ git config submodule.libnbtplusplus.url "${srcdir}/libnbtplusplus"
+ git config submodule.quazip.url "${srcdir}/quazip"
+ git submodule update
+}
+
+build() {
+ cd "${srcdir}/PolyMC"
+ mkdir -p build
+
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DLauncher_APP_BINARY_NAME="${_pkgname}" \
+ ..
+ cmake --build .
+}
+
+check() {
+ cd "${srcdir}/PolyMC/build"
+ ctest .
+}
+
+package() {
+ cd "${srcdir}/PolyMC/build"
+ DESTDIR="$pkgdir" cmake --install .
+}
+