summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2023-06-19 01:04:44 +1000
committerRod Kay2023-06-19 01:04:44 +1000
commit2177af24de8350ceabc3a3fac9b04e84685cb45e (patch)
treeef5e99bf85e0ae8feb5845c3b592cebcd3e73a6b
parent0b499f88f6c62e9af8cc5bd3f8fd9afe09e08e98 (diff)
downloadaur-2177af24de8350ceabc3a3fac9b04e84685cb45e.tar.gz
Add texlive-meta to makedepends.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD27
2 files changed, 19 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 698ea0d790d4..42034e49b59b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,8 +10,7 @@ pkgbase = polyorb
makedepends = autoconf
makedepends = python-sphinx
makedepends = python-sphinx_rtd_theme
- makedepends = texlive-core
- makedepends = texlive-latexextra
+ makedepends = texlive-meta
depends = gcc-ada
depends = xmlada
depends = gnatcoll-core
diff --git a/PKGBUILD b/PKGBUILD
index c623c8eef5e6..65f5e3cac500 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,30 @@
# Maintainer: Rod Kay <rodakay5 at gmail dot com>
pkgname=polyorb
+pkgdesc='Provides the Distributed Systems Annex (DSA) to build distributed applications with Ada.'
pkgver=20221130
pkgrel=2
-pkgdesc="Provides the Distributed Systems Annex (DSA) to build distributed applications with Ada."
-arch=('i686' 'x86_64')
-url="https://github.com/AdaCore/PolyORB"
-license=('GPL')
-depends=('gcc-ada' 'xmlada' 'gnatcoll-core' 'openssl')
-makedepends=('gprbuild' 'autoconf' 'python-sphinx' 'python-sphinx_rtd_theme' 'texlive-core' 'texlive-latexextra')
+arch=(i686 x86_64)
+url=https://github.com/AdaCore/PolyORB
+license=(GPL)
+
+depends=(gcc-ada
+ xmlada
+ gnatcoll-core
+ openssl)
+
+makedepends=(gprbuild
+ autoconf
+ python-sphinx
+ python-sphinx_rtd_theme
+ texlive-meta)
source=(https://github.com/AdaCore/PolyORB/archive/refs/heads/master.zip
patch-Makefile.in)
-sha256sums=('38432355373646713714371148d0984408be50c242a9dd30415ffbe873962206'
- 'c0703efe44949b5adb1be9fcb44110a132fbca81dda690a6623bc326df94328a')
+sha256sums=(38432355373646713714371148d0984408be50c242a9dd30415ffbe873962206
+ c0703efe44949b5adb1be9fcb44110a132fbca81dda690a6623bc326df94328a)
prepare()
@@ -59,4 +68,4 @@ package()
cd $srcdir/PolyORB-master
DESTDIR=$pkgdir make -j1 install all
-}
+} \ No newline at end of file