summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2016-12-18 21:23:22 +1100
committerRod Kay2016-12-18 21:23:22 +1100
commit292023f5f84ad172bf335fac3e8ff83d734d038d (patch)
tree5b32db8cc816551cf1570ab77f72f9f66f4faf36
parent6ed093717ed73da9d12a60a5f35ca264268414d7 (diff)
downloadaur-292023f5f84ad172bf335fac3e8ff83d734d038d.tar.gz
Update to latest svn version for 2016-12-18
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD42
-rw-r--r--patch-Makefile.in52
3 files changed, 76 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4229dc5b66f..a12750bf11c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
# Generated by mksrcinfo v8
-# Sat Dec 12 13:48:08 UTC 2015
+# Sun Dec 18 10:21:50 UTC 2016
pkgbase = polyorb
pkgdesc = PolyOrb provides the Distributed Systems Annex (DSA) to build distributed applications with Ada.
- pkgver = 2014
+ pkgver = 252702
pkgrel = 1
url = http://libre.adacore.com/libre/tools/polyorb
arch = i686
arch = x86_64
license = GPL
makedepends = nawk
+ makedepends = subversion
depends = gcc-ada
- source = http://downloads.dragonlace.net/src/polyorb-gpl-2014-src.tar.gz
+ source = svn+http://svn.eu.adacore.com/anonsvn/Dev/trunk/polyorb#revision=252702
source = patch-Makefile.in
- md5sums = 39df6ccf2d0dd19b250ba662b0b1dc4d
- md5sums = c8142456832b10c7a06343e08ffde222
+ md5sums = SKIP
+ md5sums = 40476ea50c9ac1c2473d9801e765be04
pkgname = polyorb
diff --git a/PKGBUILD b/PKGBUILD
index 43e137f85da0..10ba6f7b7325 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Rod Kay <charlie5 on #ada at freenode.net>
pkgname=polyorb
-pkgver=2014
+pkgver=252702
pkgrel=1
pkgdesc="PolyOrb provides the Distributed Systems Annex (DSA) to build distributed applications with Ada."
@@ -9,28 +9,46 @@ arch=('i686' 'x86_64')
url="http://libre.adacore.com/libre/tools/polyorb"
license=('GPL')
depends=("gcc-ada")
-makedepends=("nawk")
+makedepends=("nawk" "subversion")
-source=(http://downloads.dragonlace.net/src/$pkgname-gpl-$pkgver-src.tar.gz
+source=(svn+http://svn.eu.adacore.com/anonsvn/Dev/trunk/polyorb#revision=$pkgver
patch-Makefile.in)
-md5sums=('39df6ccf2d0dd19b250ba662b0b1dc4d'
- 'c8142456832b10c7a06343e08ffde222')
+md5sums=('SKIP'
+ '40476ea50c9ac1c2473d9801e765be04')
+prepare()
+{
+ ## Force use of pyhon2
+ #
+ cd $srcdir
+ rm -fr temp_bin
+ mkdir temp_bin
+ ln -s /usr/bin/python2 temp_bin/python
+ ln -s /usr/bin/python2-config temp_bin/python-config
-build() {
-
- cd $srcdir/$pkgname-$pkgver-src
-
+ cd $srcdir/$pkgname
patch -p0 -i ../patch-Makefile.in
+}
+
+build()
+{
+ cd $srcdir/$pkgname
+
+ PATH=$srcdir/temp_bin:$PATH
+
+ PYTHON=python2 support/reconfig
PYTHON=python2 ./configure --prefix=/usr --with-appli-perso="dsa" --with-proto-perso="giop"
make -j1
}
-package() {
- cd $srcdir/$pkgname-$pkgver-src
+package()
+{
+ cd $srcdir/$pkgname
+
+ PATH=$srcdir/temp_bin:$PATH
- DESTDIR=$pkgdir make install
+ PYTHON=python2 DESTDIR=$pkgdir make install
}
diff --git a/patch-Makefile.in b/patch-Makefile.in
index 22b2c7fbd931..bfad34a7cebc 100644
--- a/patch-Makefile.in
+++ b/patch-Makefile.in
@@ -1,6 +1,15 @@
---- Makefile.in.orig 2013-11-20 14:58:55.000000000 +0000
-+++ Makefile.in
-@@ -824,10 +824,10 @@ host=@host@
+--- Makefile.in-orig 2016-12-18 16:38:17.205009279 +1100
++++ Makefile.in 2016-12-18 17:08:10.110128607 +1100
+@@ -86,7 +86,7 @@
+ # Note: if EXTRA_GNATMAKE_FLAGS contains a -%args argument, we add -margs at
+ # the end because further builder flags may need to be passed.
+
+-COMP_TOOLS_GNATMAKE_FLAGS := @STYLE_SWITCHES@ -gnatwa@WARNINGS_MODE@ -gnat12 -gnatec=${top_builddir}/compilers/config.adc ${BASE_GNATMAKE_FLAGS}
++COMP_TOOLS_GNATMAKE_FLAGS := @STYLE_SWITCHES@ -gnatwa@WARNINGS_MODE@ -gnat12 -gnatec=${DESTDIR}${top_builddir}/compilers/config.adc ${BASE_GNATMAKE_FLAGS}
+ # Gnatmake flags for compilation tools mains, built without project files
+
+ # Extra flags for target
+@@ -847,16 +847,16 @@
target=@target@
ifeq (${target}, ${host})
@@ -13,17 +22,36 @@
+ target_exe_dir=${DESTDIR}${prefix}/bin
else
- target_prefix=${prefix}/${target}
-@@ -884,10 +884,10 @@ install:
- # pre-built and packaged with sources.
- if [ -r docs/polyorb_ug.html ]; \
+- target_prefix=${prefix}/${target}
+- host_exe_dir=${prefix}/bin
+- host_cmdprefix=${target}-
+- target_exe_dir=${target_prefix}/bin
++ target_prefix=${DESTDIR}${prefix}/${target}
++ host_exe_dir=${DESTDIR}${prefix}/bin
++ host_cmdprefix=${DESTDIR}${target}-
++ target_exe_dir=${DESTDIR}${target_prefix}/bin
+ endif
+ projects_subdir=lib/gnat/polyorb
+
+@@ -867,7 +867,7 @@
+ @echo "Install prefix: ${prefix}"
+ @echo " Host: ${host}"
+ @echo " Target: ${target}"
+- ${PINSTALL} -d ${prefix}/bin ${target_prefix}/bin
++ ${PINSTALL} -d ${DESTDIR}${prefix}/bin ${target_prefix}/bin
+ ${RM} -fr "${target_prefix}/${projects_subdir}"
+ ${PINSTALL} -d ${target_prefix}/${projects_subdir}
+ ${PINSTALL} -d ${target_prefix}/lib/polyorb
+@@ -910,10 +910,10 @@
+ # check for existence of sphinx-build.
+ if [ -r doc/_build ]; \
then \
-- (cd docs && ${MAKE} install prefix="${prefix}"); \
-+ (cd docs && ${MAKE} install prefix="${target_prefix}"); \
- elif [ -r $(top_srcdir)/docs/polyorb_ug.html ]; \
+- (cd doc && ${MAKE} install prefix="${prefix}" SPHINXBUILD=true); \
++ (cd doc && ${MAKE} install prefix="${DESTDIR}${prefix}" SPHINXBUILD=true); \
+ elif [ -r $(top_srcdir)/doc/_build ]; \
then \
-- (cd docs && ${MAKE} install prefix="${prefix}" doc_build_dir="$(top_srcdir)/docs/"); \
-+ (cd docs && ${MAKE} install prefix="${target_prefix}" doc_build_dir="$(top_srcdir)/docs/"); \
+- (cd doc && ${MAKE} install prefix="${prefix}" doc_build_dir="$(top_srcdir)/doc/" SPHINXBUILD=true); \
++ (cd doc && ${MAKE} install prefix="${DESTDIR}${prefix}" doc_build_dir="$(top_srcdir)/doc/" SPHINXBUILD=true); \
fi
# polyorb-dsa_p-partitions.ali is a special case above.