summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2020-07-18 09:05:56 +1000
committerRod Kay2020-07-18 09:05:56 +1000
commita896f2fe1166967c01dfb3d50af1ca3dd8ba464a (patch)
tree97e6aa4378a0f3ead6ab6e9830de9b6953e4b365
parent71aca26b73957b9b8768b9f39e35c1401792b40c (diff)
downloadaur-a896f2fe1166967c01dfb3d50af1ca3dd8ba464a.tar.gz
Update to 2020.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 442add202621..23c8f873c290 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = polyorb
pkgdesc = Provides the Distributed Systems Annex (DSA) to build distributed applications with Ada.
- pkgver = 20181005
+ pkgver = 20200718
pkgrel = 1
url = https://github.com/AdaCore/PolyORB
arch = i686
arch = x86_64
license = GPL
- makedepends = gprbuild>=2018
- makedepends = autoconf>=2.60
- depends = gcc-ada>=8.2.1
- depends = gcc-ada<9.0.0
+ makedepends = gprbuild
+ makedepends = autoconf
+ depends = gcc-ada
source = https://github.com/AdaCore/PolyORB/archive/master.zip
source = patch-Makefile.in
- md5sums = 465e6510ab8a2d707d36762ccfc36637
+ md5sums = ab64b033af0d9cb7c1d83665f1bb69a9
md5sums = 40476ea50c9ac1c2473d9801e765be04
pkgname = polyorb
diff --git a/PKGBUILD b/PKGBUILD
index a4f2a55b509d..204ebda113ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Rod Kay <charlie5 on #ada at freenode.net>
pkgname=polyorb
-pkgver=20181005
+pkgver=20200718
pkgrel=1
pkgdesc="Provides the Distributed Systems Annex (DSA) to build distributed applications with Ada."
arch=('i686' 'x86_64')
url="https://github.com/AdaCore/PolyORB"
license=('GPL')
-depends=('gcc-ada>=8.2.1' 'gcc-ada<9.0.0')
-makedepends=('gprbuild>=2018' 'autoconf>=2.60')
+depends=('gcc-ada')
+makedepends=('gprbuild' 'autoconf')
source=(https://github.com/AdaCore/PolyORB/archive/master.zip
patch-Makefile.in)
-md5sums=('465e6510ab8a2d707d36762ccfc36637'
+md5sums=('ab64b033af0d9cb7c1d83665f1bb69a9'
'40476ea50c9ac1c2473d9801e765be04')
prepare()
@@ -29,6 +29,9 @@ prepare()
cd $srcdir/PolyORB-master
patch -p0 -i ../patch-Makefile.in
+
+ sed -i 's/-gnatw_A//' projects/polyorb_src_dsa.gpr
+ sed -i 's/-gnatw_A//' projects/polyorb_common.gpr
}
@@ -39,7 +42,7 @@ build()
PATH=$srcdir/temp_bin:$PATH
support/reconfig
- ./configure --prefix=/usr --with-appli-perso="dsa" --with-proto-perso="giop"
+ ./configure --prefix=/usr --with-appli-perso="dsa" --with-proto-perso="giop" --enable-warnings=n
make -j1 all
}