summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2021-06-04 00:33:43 +1000
committerRod Kay2021-06-04 00:33:43 +1000
commite9bcf69915e63057025b93d55aa6b3cd38dad14f (patch)
treed1f030937074e5a990929880ce9e52940102af3f
parenta9518c1e26047e8e7d9b80ce0ec1dd0ad70ec1da (diff)
downloadaur-e9bcf69915e63057025b93d55aa6b3cd38dad14f.tar.gz
Update to latest Master release.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
-rw-r--r--patch-Makefile.in13
3 files changed, 22 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70bdcf64267e..98812e4673f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = polyorb
pkgdesc = Provides the Distributed Systems Annex (DSA) to build distributed applications with Ada.
- pkgver = 20210516
- pkgrel = 3
+ pkgver = 20210603
+ pkgrel = 1
url = https://github.com/AdaCore/PolyORB
arch = i686
arch = x86_64
@@ -15,8 +15,7 @@ pkgbase = polyorb
depends = openssl
source = https://github.com/AdaCore/PolyORB/archive/master.zip
source = patch-Makefile.in
- md5sums = 77b0b1332f8dde9b76f615c7a4cb0401
- md5sums = 40476ea50c9ac1c2473d9801e765be04
+ md5sums = 24b9ebabe5a77d97f0bc2f2f7be430fb
+ md5sums = 002a3fd9d6f9015a004f03dda36d7020
pkgname = polyorb
-
diff --git a/PKGBUILD b/PKGBUILD
index 321225b2dd62..9dec483628c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Rod Kay <charlie5 on #ada at freenode.net>
pkgname=polyorb
-pkgver=20210516
-pkgrel=3
+pkgver=20210603
+pkgrel=1
pkgdesc="Provides the Distributed Systems Annex (DSA) to build distributed applications with Ada."
arch=('i686' 'x86_64')
@@ -14,15 +14,20 @@ makedepends=('gprbuild' 'autoconf' 'python-sphinx')
source=(https://github.com/AdaCore/PolyORB/archive/master.zip
patch-Makefile.in)
-md5sums=('77b0b1332f8dde9b76f615c7a4cb0401'
- '40476ea50c9ac1c2473d9801e765be04')
+md5sums=('24b9ebabe5a77d97f0bc2f2f7be430fb'
+ '002a3fd9d6f9015a004f03dda36d7020')
prepare()
{
cd $srcdir/PolyORB-master
- patch -p0 -i ../patch-Makefile.in
+
+ patch -p1 -i ../patch-Makefile.in
+ support/reconfig
+
+ # 'support/reconfig' does not generate the 'compile' and 'missing' files, so create them.
+ #
touch support/compile
touch support/missing
}
@@ -32,7 +37,6 @@ build()
{
cd $srcdir/PolyORB-master
- support/reconfig
./configure --prefix=/usr \
--enable-warnings=n \
--with-gprbuild=yes \
@@ -41,8 +45,8 @@ build()
--with-proto-perso="giop soap" \
--with-corba-services="event ir naming notification time" \
--with-openssl
+
make -j1 all
- make -j1 examples
make -j1 docs
}
diff --git a/patch-Makefile.in b/patch-Makefile.in
index bfad34a7cebc..7b1f62a4f7e3 100644
--- a/patch-Makefile.in
+++ b/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in-orig 2016-12-18 16:38:17.205009279 +1100
-+++ Makefile.in 2016-12-18 17:08:10.110128607 +1100
+--- PolyORB-master-old/Makefile.in
++++ PolyORB-master/Makefile.in
@@ -86,7 +86,7 @@
# Note: if EXTRA_GNATMAKE_FLAGS contains a -%args argument, we add -margs at
# the end because further builder flags may need to be passed.
@@ -9,7 +9,7 @@
# Gnatmake flags for compilation tools mains, built without project files
# Extra flags for target
-@@ -847,16 +847,16 @@
+@@ -626,16 +626,16 @@
target=@target@
ifeq (${target}, ${host})
@@ -33,7 +33,7 @@
endif
projects_subdir=lib/gnat/polyorb
-@@ -867,7 +867,7 @@
+@@ -646,7 +646,7 @@
@echo "Install prefix: ${prefix}"
@echo " Host: ${host}"
@echo " Target: ${target}"
@@ -42,8 +42,8 @@
${RM} -fr "${target_prefix}/${projects_subdir}"
${PINSTALL} -d ${target_prefix}/${projects_subdir}
${PINSTALL} -d ${target_prefix}/lib/polyorb
-@@ -910,10 +910,10 @@
- # check for existence of sphinx-build.
+@@ -689,10 +689,10 @@
+ # check for existence of sphinx-build.
if [ -r doc/_build ]; \
then \
- (cd doc && ${MAKE} install prefix="${prefix}" SPHINXBUILD=true); \
@@ -55,3 +55,4 @@
fi
# polyorb-dsa_p-partitions.ali is a special case above.
+