summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Tharp2017-02-02 00:28:41 -0600
committerAlex Tharp2017-02-02 00:28:41 -0600
commit814bb084588fa91372bb42a6b0af1fab1eae80a3 (patch)
treec8ae0e6dfeb7b4fe4d84a983cc03987f83ecf651
parentdd3a8fc3b2744fde2c29f7414476930d00849f92 (diff)
downloadaur-814bb084588fa91372bb42a6b0af1fab1eae80a3.tar.gz
fix: resolve compilation issues, don't build examples or tests, fix LICENSE.txt copying
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 388ebe15173a..eed392b49d9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jan 18 05:32:52 UTC 2016
+# Thu Feb 2 06:27:03 UTC 2017
pkgbase = polyvox-git
pkgdesc = PolyVox is a library for storing, manipulating, and displaying volumetric representations of objects
- pkgver = r1108.95f0aa2
+ pkgver = r2156.c986c9f0
pkgrel = 1
url = http://www.volumesoffun.com/polyvox-about/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 98d32aeeb7d8..9e13fd5015ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Issues: https://github.com/toastercup/aur-packages/issues
pkgname=polyvox-git
-pkgver=r1108.95f0aa2
+pkgver=r2156.c986c9f0
pkgrel=1
pkgdesc="PolyVox is a library for storing, manipulating, and displaying volumetric representations of objects"
arch=('i686' 'x86_64')
@@ -21,7 +21,7 @@ pkgver() {
build() {
cd $srcdir && mkdir -p build && cd $_
- cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_BUILD_TYPE:STRING=Release "../$pkgname"
+ cmake -DENABLE_EXAMPLES=OFF -DENABLE_TESTS=OFF -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_BUILD_TYPE:STRING=Release "../$pkgname"
make
}
@@ -29,5 +29,6 @@ package() {
cd "$srcdir/build"
make DESTDIR="$pkgdir/" install
mkdir -p "$pkgdir/usr/share/licenses/$pkgname/"
- cp "$srcdir/$pkgname/LICENSE.TXT" "$pkgdir/usr/share/licenses/$pkgname/"
+ cp "$srcdir/$pkgname/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/"
}
+