summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPouyan Heyratpour2023-07-28 23:52:17 +0330
committerPouyan Heyratpour2023-07-28 23:52:17 +0330
commitd72f4783ed15090027fc9b50fea3cf68a4572859 (patch)
tree8d24db5314e24353baf0940386e31ab48da62ca8
parentad07a072504a94a772e52be1decdc00a79526951 (diff)
downloadaur-d72f4783ed15090027fc9b50fea3cf68a4572859.tar.gz
install from binary release
Signed-off-by: Pouyan Heyratpour <pouyan@janstun.com>
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD23
2 files changed, 11 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9208c51c2df..3cd2c5ea53ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,9 @@
pkgbase = polywatch
pkgdesc = File change watcher with filter & rate limit feature which run command(s) when file change events happen
- pkgver = 1.0.1
+ pkgver = 1.1.0
pkgrel = 1
url = https://pouyanh.github.io/polywatch/
arch = any
license = GPL3
- makedepends = go
- source = polywatch-1.0.1.tar.gz::https://github.com/pouyanh/polywatch/archive/v1.0.1.tar.gz
- md5sums = 90bc6e427ff6f1914163de1024123290
pkgname = polywatch
diff --git a/PKGBUILD b/PKGBUILD
index 322421b7b797..7a6f6db3e888 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,23 @@
# Maintainer: Pouyan Heyratpour <pouyan@janstun.com>
pkgname=polywatch
-pkgver=1.0.1
+pkgver=1.1.0
pkgrel=1
pkgdesc="File change watcher with filter & rate limit feature which run command(s) when file change events happen"
arch=('any')
url="https://pouyanh.github.io/polywatch/"
license=('GPL3')
depends=()
-makedepends=('go')
-source=(${pkgname}-${pkgver}.tar.gz::https://github.com/pouyanh/polywatch/archive/v${pkgver}.tar.gz)
-md5sums=('90bc6e427ff6f1914163de1024123290')
-
-build() {
- cd "${pkgname}-${pkgver}"
-
- go mod tidy
- go build ./cmd/polywatch
-}
+makedepends=()
+source_i686=(${pkgname}-${pkgver}.tar.gz::https://github.com/pouyanh/polywatch/releases/download/v${pkgver}/polywatch-v${pkgver}-linux-386.tar.gz)
+md5sums_i686=('47798a66a4718e7c543b68272c2e0140')
+source_x86_64=(${pkgname}-${pkgver}.tar.gz::https://github.com/pouyanh/polywatch/releases/download/v${pkgver}/polywatch-v${pkgver}-linux-amd64.tar.gz)
+md5sums_x86_64=('06f4a35ca68a444eb17c5ed05206029b')
+source_armv7h=(${pkgname}-${pkgver}.tar.gz::https://github.com/pouyanh/polywatch/releases/download/v${pkgver}/polywatch-v${pkgver}-linux-arm.tar.gz)
+md5sums_armv7h=('453860966d1adff7503dfee3e3bd020d')
+source_aarch64=(${pkgname}-${pkgver}.tar.gz::https://github.com/pouyanh/polywatch/releases/download/v${pkgver}/polywatch-v${pkgver}-linux-arm64.tar.gz)
+md5sums_aarch64=('6fb9803aa43be7db6d8c971b4458e158')
package() {
- cd "${pkgname}-${pkgver}"
-
install -Dm 755 polywatch -t "${pkgdir}/usr/bin"
} \ No newline at end of file