summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPouyan Heyratpour2023-07-28 21:09:33 +0330
committerPouyan Heyratpour2023-07-28 21:09:33 +0330
commit854005316a1a49bb67600d25fd9aa6655f4be5a4 (patch)
treef857b7b940f8f53a8d7c09b3383ce6ae5a660d51
downloadaur-854005316a1a49bb67600d25fd9aa6655f4be5a4.tar.gz
make package from source
Signed-off-by: Pouyan Heyratpour <pouyan@janstun.com>
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49f07ba84aa1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = polywatch-git
+ pkgdesc = File change watcher with filter & rate limit feature which run command(s) when file change events happen
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://pouyanh.github.io/polywatch/
+ arch = any
+ license = GPL3
+ makedepends = go
+ makedepends = goreleaser
+ provides = polywatch
+ conflicts = polywatch
+ source = polywatch-git-1.1.1.tar.gz::https://github.com/pouyanh/polywatch/archive/v1.1.1.tar.gz
+ md5sums = a8477e7de275c826eb108871f7c40026
+
+pkgname = polywatch-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de2ae9e8165e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Pouyan Heyratpour <pouyan@janstun.com>
+
+pkgname=polywatch-git
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="File change watcher with filter & rate limit feature which run command(s) when file change events happen"
+arch=('any')
+url="https://pouyanh.github.io/polywatch/"
+license=('GPL3')
+depends=()
+makedepends=('go' 'goreleaser')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/pouyanh/polywatch/archive/v${pkgver}.tar.gz)
+md5sums=('a8477e7de275c826eb108871f7c40026')
+provides=('polywatch')
+conflicts=('polywatch')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ go mod tidy
+ go build ./cmd/polywatch
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ install -Dm 755 polywatch -t "${pkgdir}/usr/bin"
+} \ No newline at end of file