summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPouyan Heyratpour2023-07-28 22:58:30 +0330
committerPouyan Heyratpour2023-07-28 22:58:30 +0330
commitf1327f62de7edb927dea47e5876185caf0908e2c (patch)
tree83db49d678e4eb58ceef32a2518dc125b94f8e3c
parent854005316a1a49bb67600d25fd9aa6655f4be5a4 (diff)
downloadaur-f1327f62de7edb927dea47e5876185caf0908e2c.tar.gz
build using goreleaser
Signed-off-by: Pouyan Heyratpour <pouyan@janstun.com>
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de2ae9e8165e..ff2aca15b835 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,14 +15,13 @@ provides=('polywatch')
conflicts=('polywatch')
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname%-git}-${pkgver}"
- go mod tidy
- go build ./cmd/polywatch
+ goreleaser build --snapshot --clean --single-target -o dist/polywatch
}
package() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname%-git}-${pkgver}"
- install -Dm 755 polywatch -t "${pkgdir}/usr/bin"
+ install -Dm 755 dist/polywatch -t "${pkgdir}/usr/bin"
} \ No newline at end of file