summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2024-01-04 03:21:06 -0500
committerChris Severance2024-01-04 03:21:06 -0500
commit9b8331317b220d529beb2198e28ad3a76ca79c6b (patch)
tree29af84c82119ee9feec6359b6892aef076a09bdc
parent08fa39dc8aa0cdb96f4dbe7bb4b5d590e3368d7a (diff)
downloadaur-pom-ng-git.tar.gz
autu: Update to 0.0.19.r2.gcb92fb7-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD30
2 files changed, 15 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 164401bc0c66..8aa3b7aaa89a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Oct 11 14:28:23 UTC 2017
pkgbase = pom-ng-git
pkgdesc = Packet-o-Matic real time network packet capture forensic tool
- pkgver = 0.0.19.r0.g48da973
+ pkgver = 0.0.19.r2.gcb92fb7
pkgrel = 1
url = http://www.packet-o-matic.org/
arch = i686
@@ -31,8 +29,8 @@ pkgbase = pom-ng-git
optdepends = pom-ng-addons
provides = pom-ng=0.0.19
conflicts = pom-ng
- source = POM-NG-GIT::git://github.com/gmsoft-tuxicoman/pom-ng.git
+ source = POM-NG-GIT::git+https://github.com/gmsoft-tuxicoman/pom-ng.git
+ md5sums = SKIP
sha256sums = SKIP
pkgname = pom-ng-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 326c6eb94076..5707b5772a5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
set -u
_pkgname='pom-ng'
pkgname="${_pkgname}-git"
-pkgver=0.0.19.r0.g48da973
+pkgver=0.0.19.r2.gcb92fb7
pkgrel=1
pkgdesc='Packet-o-Matic real time network packet capture forensic tool'
arch=('i686' 'x86_64')
@@ -33,7 +33,8 @@ conflicts=("${_pkgname}")
_srcdir="${pkgname^^}"
_giturl="https://github.com/gmsoft-tuxicoman/${_pkgname}"
_verwatch=("${_giturl}/releases.atom" '\s\+<title>v\([^<]\+\).*' 'f') # RSS
-source=("${_srcdir}::${_giturl//https:/git:}.git")
+source=("${_srcdir}::git+${_giturl}.git")
+md5sums=('SKIP')
sha256sums=('SKIP')
pkgver () {
@@ -43,26 +44,19 @@ pkgver () {
set +u
}
-prepare() {
- set -u
- cd "${_srcdir}"
- autoreconf -f -i
- lua_CFLAGS="$(pkg-config --cflags lua51)" \
- lua_LIBS="$(pkg-config --libs lua51)" \
- ./configure --prefix='/usr'
- #cp -p '/usr/include/libexif/exif-data.h' .
- set +u
-}
-
build() {
set -u
cd "${_srcdir}"
- if [ ! -z "${MAKEFLAGS:-}" ] && [ "${MAKEFLAGS}" != "${MAKEFLAGS//-j/}" ]; then
- nice make -s
- else
- local _nproc="$(lscpu -p | grep '^[0-9]' | cut -d',' -f2-3 | sort -u | wc -l)"; _nproc=$((_nproc>4?4:_nproc))
- nice make -s -j "${_nproc}"
+ if [ ! -s 'configure' ]; then
+ autoreconf -f -i
+ fi
+ if [ ! -s 'Makefile' ]; then
+ lua_CFLAGS="$(pkg-config --cflags lua51)" \
+ lua_LIBS="$(pkg-config --libs lua51)" \
+ ./configure --prefix='/usr'
+ #cp -p '/usr/include/libexif/exif-data.h' .
fi
+ nice make -s
set +u
}