summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Ogilvy2021-01-04 02:39:31 +0000
committerStephen Ogilvy2021-01-04 02:39:31 +0000
commit59f87dc2bfd6ee48e4d3398ab6e04031ad4cf9b2 (patch)
tree7d6ffec457663ad50de27561a0a75a7a17b81ef7
downloadaur-59f87dc2bfd6ee48e4d3398ab6e04031ad4cf9b2.tar.gz
added PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88b458d48212
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pomeron-gtk-theme-git
+ pkgdesc = Dark, red GTK theme for GNOME desktops
+ pkgver = 20210104.05060ea
+ pkgrel = 1
+ url = https://github.com/hypernormalisation/Pomeron-GTK
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = gtk-engine-murrine
+ depends = gtk-engines
+ depends = gtk3
+ optdepends = tela-circle-icon-theme-git: pairs well with this icon theme
+ provides = pomeron-gtk-theme
+ conflicts = pomeron-gtk-theme
+ options = !strip
+ source = pomeron-gtk-theme::git+https://github.com/hypernormalisation/Pomeron-GTK
+ sha256sums = SKIP
+
+pkgname = pomeron-gtk-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c0dbb1896cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Stephen Ogilvy <hypernormalisation at tuta dot io>
+pkgname=pomeron-gtk-theme-git
+pkgver=20210104.05060ea
+pkgrel=1
+pkgdesc="Dark, red GTK theme for GNOME desktops"
+arch=('any')
+url="https://github.com/hypernormalisation/Pomeron-GTK"
+license=('GPL')
+depends=('gtk-engine-murrine' 'gtk-engines' 'gtk3')
+makedepends=('git')
+optdepends=('tela-circle-icon-theme-git: pairs well with this icon theme')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+options=('!strip')
+source=("${pkgname%-git}::git+https://github.com/hypernormalisation/Pomeron-GTK")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/pomeron-gtk-theme"
+ local date=$(date --date "$(git show -s --format=%ci)" +%Y%m%d)
+ local commit=$(git rev-parse --short HEAD)
+ echo $date.$commit
+}
+
+package() {
+ DESTDIR="$pkgdir/usr/share/themes"
+ mkdir -p "$DESTDIR"
+ cd "$srcdir"
+ cp -r pomeron-gtk-theme "$DESTDIR/"
+}