summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkawaegle2021-05-13 09:02:06 +0200
committerkawaegle2021-05-13 09:02:06 +0200
commite5a3e45d12dc11261d0e562c772d62d311d8a21e (patch)
tree0318006c74514cfb5f41029f0c56e230b93b1682
downloadaur-e5a3e45d12dc11261d0e562c772d62d311d8a21e.tar.gz
work on pkgbuild
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ae9bf8799ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pomodoro.py
+ pkgdesc = Pomodoro notify with polybar output
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/kawaegle/Pomodoro
+ arch = any
+ license = GPL
+ depends = python>=3.8
+ depends = libnotify>=0.7.5
+ depends = dunst
+ optdepends = ttf-font-awesome: show beautifull icon
+ provides = pomodoro.py
+ source = https://github.com/kawaegle/Pomodoro/
+ md5sums = SKIP
+
+pkgname = pomodoro.py
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1bb522163c12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+#Maintainer: alecromski alecromski@gmail.com
+
+pkgname=pomodoro.py
+pkgver=1.0
+pkgrel=1
+pkgdesc="Pomodoro notify with polybar output"
+arch=('any')
+url="https://github.com/kawaegle/Pomodoro"
+license=('GPL')
+depends=('python>=3.8' 'libnotify>=0.7.5' 'dunst')
+provides=('pomodoro.py')
+optdepends=('ttf-font-awesome: show beautifull icon')
+conflics=('pomodoro')
+source=("https://github.com/kawaegle/Pomodoro/")
+md5sums=('SKIP')
+package(){
+ cd Pomodoro
+ printf "$(pwd)"
+ cp pomodoro.py $HOME/.local/bin.
+ printf "Install finished"
+}