summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShimi Chen2015-07-07 00:10:28 +0300
committerShimi Chen2015-07-07 00:10:28 +0300
commitd2accf1477a8157797671983cdb895cd7ef814aa (patch)
treef96090c8034730ca4ca830a26a81634f55355237
downloadaur-d2accf1477a8157797671983cdb895cd7ef814aa.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD20
-rw-r--r--pondus.install4
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad1eee4e8587
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by makepkg 4.2.1
+# Wed May 6 16:47:56 UTC 2015
+pkgbase = pondus
+ pkgdesc = personal weight management program written in Python and GTK2
+ pkgver = 0.8.0
+ pkgrel = 2
+ url = http://www.ephys.de/software/pondus/
+ install = pondus.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ depends = pygtk>=2.6
+ depends = hicolor-icon-theme
+ optdepends = python2-matplotlib: graph support
+ source = http://bitbucket.org/eike/pondus/downloads/pondus-0.8.0.tar.gz
+ md5sums = 1e95794ce69c516faf4e57b858ff0fe1
+
+pkgname = pondus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c661cbd5adb8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Shimi Chen <shimi.chen@gmail.com>
+# Contributor: jcerdan <jcerdan@tecob.com>
+pkgname=pondus
+pkgver=0.8.0
+pkgrel=2
+pkgdesc="personal weight management program written in Python and GTK2"
+arch=('i686' 'x86_64')
+url="http://www.ephys.de/software/pondus/"
+license=('GPL')
+depends=('python2' 'pygtk>=2.6' 'hicolor-icon-theme')
+optdepends=('python2-matplotlib: graph support')
+makedepends=('')
+install='pondus.install'
+source=(http://bitbucket.org/eike/pondus/downloads/$pkgname-$pkgver.tar.gz)
+md5sums=('1e95794ce69c516faf4e57b858ff0fe1')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 ./setup.py install --root=$pkgdir/
+}
diff --git a/pondus.install b/pondus.install
new file mode 100644
index 000000000000..0f76b787b687
--- /dev/null
+++ b/pondus.install
@@ -0,0 +1,4 @@
+post_install() {
+ gtk-update-icon-cache -f /usr/share/icons/hicolor
+}
+