summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandr Boiko2017-05-04 18:11:56 +1100
committerAlexandr Boiko2017-05-04 18:11:56 +1100
commit7a05e3d06f8d2bd39f2c1f66849c7ef573d54a60 (patch)
tree5c8be351b4ecd7383fb1cc87e68e6e7d15e7ee41
downloadaur-7a05e3d06f8d2bd39f2c1f66849c7ef573d54a60.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD42
-rw-r--r--ponomar.desktop9
-rw-r--r--ponomar.install10
-rw-r--r--ponomar.pngbin0 -> 264 bytes
-rw-r--r--ponomar.sh18
-rw-r--r--profile.sh4
7 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df21f318d9ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Thu May 4 07:11:06 UTC 2017
+pkgbase = ponomar
+ pkgdesc = Ponomar: a liturgics suite for the Orthodox Church http://www.ponomar.net/
+ pkgver = 0.80.0d8052d
+ pkgrel = 1
+ url = http://www.ponomar.net/
+ install = ponomar.install
+ arch = any
+ license = GPL
+ depends = java-runtime
+ depends = texinfo
+ source = https://github.com/typiconman/ponomar/archive/master.zip
+ source = ponomar.desktop
+ source = ponomar.sh
+ source = ponomar.png
+ source = profile.sh
+ md5sums = b2f8b00fdb4aa884f72c575fb6528967
+ md5sums = e58c1c7420ac16aee3022187e77d4bd2
+ md5sums = ace315ef0155455422ee60fb5de3d428
+ md5sums = d8b4f7dd400cd7240ec63c8bcaddaec6
+ md5sums = ec1af1f47c6770f55d23c74880a9d437
+
+pkgname = ponomar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..120d184d4c9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Aleksandr <orthodox dot tk at gmail dot com>
+pkgname=ponomar
+pkgver=0.80.0d8052d
+pkgrel=1
+pkgdesc="Ponomar: a liturgics suite for the Orthodox Church http://www.ponomar.net/"
+arch=('any')
+url="http://www.ponomar.net/"
+license=('GPL')
+groups=()
+depends=('java-runtime' 'texinfo')
+install=$pkgname.install
+source=("https://github.com/typiconman/ponomar/archive/master.zip"
+ "$pkgname.desktop"
+ "$pkgname.sh"
+ "$pkgname.png"
+ "profile.sh")
+md5sums=('b2f8b00fdb4aa884f72c575fb6528967'
+ 'e58c1c7420ac16aee3022187e77d4bd2'
+ 'ace315ef0155455422ee60fb5de3d428'
+ 'd8b4f7dd400cd7240ec63c8bcaddaec6'
+ 'ec1af1f47c6770f55d23c74880a9d437')
+
+build() {
+ cd "$srcdir/$pkgname-master"
+ make
+}
+
+package() {
+ cd "$srcdir"
+ install -dm755 "$pkgdir/etc/profile.d"
+ install -dm755 "$pkgdir/opt"
+ install -dm755 "$pkgdir/usr/share/applications"
+ install -dm755 "$pkgdir/usr/share/pixmaps"
+ install -dm755 "$pkgdir/usr/bin"
+ cp -r "$pkgname-master" "$pkgdir/opt/$pkgname"
+ install -Dm755 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm755 $pkgname.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm755 $pkgname.sh "$pkgdir/opt/$pkgname/$pkgname.sh"
+ install -Dm755 profile.sh "$pkgdir/etc/profile.d/$pkgname.sh"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ponomar.desktop b/ponomar.desktop
new file mode 100644
index 000000000000..f75d34114978
--- /dev/null
+++ b/ponomar.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Ponomar
+Comment=Ponomar Project
+Exec=ponomar.sh
+Icon=ponomar.png
+Type=Application
+Terminal=false
+Categories=Office;
diff --git a/ponomar.install b/ponomar.install
new file mode 100644
index 000000000000..bd45fe178952
--- /dev/null
+++ b/ponomar.install
@@ -0,0 +1,10 @@
+# arg 1: the new package version
+post_install() {
+ echo
+ echo
+ echo ":: NOTE"
+ echo ":: After the install you must relog."
+ echo
+ echo
+}
+
diff --git a/ponomar.png b/ponomar.png
new file mode 100644
index 000000000000..16a0ff1d3b38
--- /dev/null
+++ b/ponomar.png
Binary files differ
diff --git a/ponomar.sh b/ponomar.sh
new file mode 100644
index 000000000000..2bc33f91642b
--- /dev/null
+++ b/ponomar.sh
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+cd ${0%${0##*/}}.
+
+PONOMAR_DIR=${PONOMAR_DIR}
+CLASSPATH=${PONOMAR_DIR}:${PONOMAR_DIR}/Ponomar/*
+
+# update
+#if [ -d ${BGBILLING_DIR}/lib.update ];
+#then
+# mv -f ${BGBILLING_DIR}/lib.update/* ${BGBILLING_DIR}/lib
+# rm -fr ${BGBILLING_DIR}/lib.update
+#fi
+
+#java -Dupdate.folder=${BGBILLING_DIR}/lib.update -Dawt.useSystemAAFontSettings=on -Dsun.java2d.xrender=true -Djava.net.preferIPv4Stack=true -Dsun.net.client.defaultConnectTimeout=1000 -Djavax.net.ssl.trustStore=.keystore -Xmx512m -Duser.language=ru -Duser.region=RU -cp ${CLASSPATH} ru.bitel.bgbilling.client.BGClient&
+
+java -Dawt.useSystemAAFontSettings=on -Dsun.java2d.xrender=true -cp ${CLASSPATH} Ponomar.Main&
+
diff --git a/profile.sh b/profile.sh
new file mode 100644
index 000000000000..13a59a1eaad3
--- /dev/null
+++ b/profile.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+export PONOMAR_DIR=/opt/ponomar
+export PATH=$PATH:$PONOMAR_DIR