summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormyself6002022-12-16 10:12:44 +0100
committermyself6002022-12-16 10:12:44 +0100
commit7a9348d4d5e8a8b67c21f361885d556dbc00c935 (patch)
treec0ea56c6e97bbae2d5cf2d2a44d43b54caaf88d7
parent254913b32ce404f6490a617ebec4ec439412d12b (diff)
downloadaur-7a9348d4d5e8a8b67c21f361885d556dbc00c935.tar.gz
Fix pkgver
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 616d4aac3eb9..57ad7d6b136e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ponscripter
pkgdesc = Fork of the Ponscripter visual novel engine to take advantage of SDL2 and improve Steam integration
- pkgver = v3.0.0
- pkgrel = 2
+ pkgver = v3.0.1
+ pkgrel = 1
epoch = 1
url = https://github.com/07th-mod/ponscripter-fork
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = ponscripter
depends = sdl2_mixer
depends = smpeg2
depends = freetype2
- source = git+https://github.com/07th-mod/ponscripter-fork.git#tag=v3.0.0
+ source = git+https://github.com/07th-mod/ponscripter-fork.git#tag=v3.0.1
md5sums = SKIP
pkgname = ponscripter
diff --git a/PKGBUILD b/PKGBUILD
index 22adfe31dfe2..f9cf810e4a60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,18 @@
pkgname=ponscripter
-pkgver=`curl -s https://api.github.com/repos/07th-mod/ponscripter-fork/releases/latest|grep tag_name|cut -d\" -f4`
-pkgrel=2
+pkgver=v3.0.1
+_pkgver=`curl -s https://api.github.com/repos/07th-mod/ponscripter-fork/releases/latest|grep tag_name|cut -d\" -f4`
+pkgrel=1
epoch=1
pkgdesc="Fork of the Ponscripter visual novel engine to take advantage of SDL2 and improve Steam integration"
arch=(x86_64 aarch64)
url=https://github.com/07th-mod/ponscripter-fork
license=(GPL2)
depends=(sdl2_{image,mixer} smpeg2 freetype2)
-source=(git+https://github.com/07th-mod/ponscripter-fork.git#tag=$pkgver)
+source=(git+https://github.com/07th-mod/ponscripter-fork.git#tag=$_pkgver)
md5sums=(SKIP)
+pkgver(){
+ echo $_pkgver
+}
build(){
cd $pkgname-fork
./configure --with-external-sdl-mixer