summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormyself6002022-12-28 17:21:56 +0100
committermyself6002022-12-28 17:21:56 +0100
commit21ac57e343b91c52395f9b5312ad785e4e84fbf7 (patch)
treeceb8abadb639ca07e886ce58ea36b65fc5e5d585
downloadaur-21ac57e343b91c52395f9b5312ad785e4e84fbf7.tar.gz
Upload files
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3715816749cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ponscripter-bin
+ pkgdesc = Fork of the Ponscripter visual novel engine to take advantage of SDL2 and improve Steam integration
+ pkgver = v3.0.1
+ pkgrel = 1
+ url = https://github.com/07th-mod/ponscripter-fork
+ arch = x86_64
+ arch = aarch64
+ license = GPL
+ depends = sdl2_mixer
+ depends = freetype2
+ provides = ponscripter
+ conflicts = ponscripter
+ source = https://github.com/07th-mod/ponscripter-fork/releases/download/v3.0.1/ponscr-linux.zip
+ md5sums = SKIP
+ depends_aarch64 = box64
+
+pkgname = ponscripter-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f5c0def1721
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=ponscripter-bin
+pkgver=v3.0.1
+_pkgver=`curl -s https://api.github.com/repos/07th-mod/ponscripter-fork/releases/latest|grep tag_name|cut -d\" -f4`
+pkgrel=1
+pkgdesc="Fork of the Ponscripter visual novel engine to take advantage of SDL2 and improve Steam integration"
+arch=(x86_64 aarch64)
+url=https://github.com/07th-mod/ponscripter-fork
+license=(GPL)
+depends=(sdl2_mixer freetype2)
+depends_aarch64=(box64)
+provides=(ponscripter)
+conflicts=(ponscripter)
+source=(`curl -s https://api.github.com/repos/07th-mod/ponscripter-fork/releases/latest|grep browser_download_url|cut -d\" -f4|grep 'linux\.'`)
+md5sums=(SKIP)
+pkgver(){
+ echo $_pkgver
+}
+package(){
+ [ $CARCH = x86_64 ] &&
+ install ponscr -Dt "$pkgdir"/usr/bin ||
+ install ponscr -D "$pkgdir"/usr/bin/ponscr-x86_64
+ echo -e '#!/bin/sh\nbox64 ponscr-x86_64'>"$pkgdir"/usr/bin/ponscr
+ chmod +x "$pkgdir"/usr/bin/ponscr
+}