summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormyself6002024-02-05 21:38:12 +0100
committermyself6002024-02-05 21:38:12 +0100
commit3fd2e6769b6b932e65e86134d8d789549e22b6ef (patch)
tree63d3dac53d50ca50da8f47faf35b0c8c0156825e
parent05610cf8773aeeb849458892b72abb80eca1cd5b (diff)
downloadaur-3fd2e6769b6b932e65e86134d8d789549e22b6ef.tar.gz
Import from https://codeberg.org/myself600/aur/src/branch/main/ponscripter-bin
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
-rw-r--r--update.sh2
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6bcce2482a51..00ab749624f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ponscripter-bin
pkgdesc = Fork of the Ponscripter visual novel engine to take advantage of SDL2 and improve Steam integration
- pkgver = v3.0.2
+ pkgver = 4.0.0
pkgrel = 1
url = https://github.com/07th-mod/ponscripter-fork
arch = x86_64
@@ -10,8 +10,9 @@ pkgbase = ponscripter-bin
depends = freetype2
provides = ponscripter
conflicts = ponscripter
- source = https://github.com/07th-mod/ponscripter-fork/releases/download/v3.0.2/ponscr-3.0.2-linux.zip
- md5sums = SKIP
+ options = !strip
+ source = https://github.com/07th-mod/ponscripter-fork/releases/download/v4.0.0/ponscr-4.0.0-linux.zip
+ cksums = SKIP
depends_aarch64 = box64
pkgname = ponscripter-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5f0fb1bda118..4ff364d62858 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,21 @@
pkgname=ponscripter-bin
-pkgver=v3.0.2
-_pkgver=`curl -s https://api.github.com/repos/07th-mod/ponscripter-fork/releases/latest|grep tag_name|cut -d\" -f4`
+pkgver=4.0.0
pkgrel=1
-pkgdesc="Fork of the Ponscripter visual novel engine to take advantage of SDL2 and improve Steam integration"
+pkgdesc='Fork of the Ponscripter visual novel engine to take advantage of SDL2 and improve Steam integration'
arch=(x86_64 aarch64)
url=https://github.com/07th-mod/ponscripter-fork
license=(GPL)
depends=(sdl2_mixer freetype2)
depends_aarch64=(box64)
provides=(ponscripter)
-conflicts=(ponscripter)
-source=(`curl -s https://api.github.com/repos/07th-mod/ponscripter-fork/releases/latest|grep browser_download_url|cut -d\" -f4|grep 'linux\.'`)
-md5sums=(SKIP)
-pkgver(){
- echo $_pkgver
-}
+conflicts=($provides)
+options=(!strip)
+source=($url/releases/download/v$pkgver/ponscr-$pkgver-linux.zip)
+cksums=(SKIP)
package(){
[ $CARCH = x86_64 ] && install ponscr -Dt "$pkgdir"/usr/bin || {
- install ponscr -D "$pkgdir"/usr/bin/ponscr-x86_64
- echo -e '#!/bin/sh\nbox64 ponscr-x86_64 "$@"'>"$pkgdir"/usr/bin/ponscr # force box64 if binfmt is missing
+ install ponscr -D "$pkgdir"/usr/bin/ponscr.bin
+ echo -e '#!/bin/sh\nbox64 ponscr.bin "$@"'>"$pkgdir"/usr/bin/ponscr # force box64 if binfmt is missing
chmod +x "$pkgdir"/usr/bin/ponscr
}
}
diff --git a/update.sh b/update.sh
new file mode 100644
index 000000000000..aaedbc5d2b57
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,2 @@
+pkgver=`curl -s https://api.github.com/repos/07th-mod/ponscripter-fork/releases/latest|grep tag_name|cut -d\" -f4`
+sed -i /^pkgver=/s/=.*/=${pkgver/v}/ PKGBUILD