aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier Francisco2018-03-22 00:05:53 +0000
committerXavier Francisco2018-03-22 00:05:53 +0000
commit83f02ba81c346b92755092859e75e7d963e8bc22 (patch)
tree3d7fa2482b1f059875ef0ad3a312eb1bf5f139eb
downloadaur-83f02ba81c346b92755092859e75e7d963e8bc22.tar.gz
First commit
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD36
-rw-r--r--README.md2
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1683b73d43da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pony-stable-git
+ pkgdesc = A simple dependency manager for the Pony language.
+ pkgver = 0.1.0.13.g8b4f3ac
+ pkgrel = 1
+ url = https://github.com/ponylang/pony-stable
+ arch = i686
+ arch = x86_64
+ license = BSD-2-Clause
+ makedepends = git sed
+ depends = ponyc
+ provides = pony-stable
+ conflicts = pony-stable
+ backup = etc/pony-stable/pony-stable.conf
+ source = pony-stable::git+https://github.com/ponylang/pony-stable.git
+ md5sums = SKIP
+
+pkgname = pony-stable-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..5a53770e2dc9
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2018 Xavier Francisco
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2e48d44b010
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Xavier Francisco <echo moc.liamg@ocsicnarf.n.reivax | rev>
+
+# PKGBUILD script for pony-stable upstream, git version
+# pony-stable is a package manager for pony lang
+_pkgname=pony-stable
+pkgname=$_pkgname-git
+pkgver=0.1.0.13.g8b4f3ac
+pkgrel=1
+pkgdesc="A simple dependency manager for the Pony language."
+arch=('i686' 'x86_64')
+url="https://github.com/ponylang/pony-stable"
+license=('BSD-2-Clause')
+groups=()
+depends=('ponyc')
+makedepends=('git sed')
+# optdepends=('***: for that thing *** does')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+backup=("etc/$_pkgname/$_pkgname.conf")
+source=("$_pkgname::git+https://github.com/ponylang/pony-stable.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --tags | sed 's|-|.|g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make install prefix="$pkgdir/usr" sysconfdir="$pkgdir/etc/local/$_pkgname"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..be3dc44bc9a6
--- /dev/null
+++ b/README.md
@@ -0,0 +1,2 @@
+# pony-stable-pkgbuild
+PKGBUILD for pony-stable