summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2015-06-11 19:08:43 +0200
committerMattias Andrée2015-06-11 19:08:43 +0200
commit53bcc68463d6b092ae281fb20fb567aed34f2afa (patch)
tree6dfacb5115e6f814a6581daca50c8dcd5f1321c6
downloadaur-pony.computer.tar.gz
Initial import, version 1428445028
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD34
-rw-r--r--pony.computer.install20
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90b599924633
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = pony.computer
+ pkgdesc = Show computer information and a pony
+ pkgver = 1428445028
+ pkgrel = 1
+ url = https://github.com/GNU-Pony/pony.computer
+ install = pony.computer.install
+ arch = any
+ license = GPL3
+ makedepends = make
+ makedepends = coreutils
+ makedepends = sed
+ makedepends = texinfo
+ depends = sh
+ depends = ponysay
+ depends = coreutils
+ depends = python3
+ optdepends = linux: Additional system information can be provided with Linux kernel's procfs /proc
+ optdepends = filesystem: Identification of distribution
+ optdepends = lsb-release: Identification of distribution
+ source = https://github.com/GNU-Pony/pony.computer/archive/1428445028.tar.gz
+ sha256sums = 997f8be119e36cbbdcafee2126ceccfac3e6551d839b78a93aba748f33d4469d
+
+pkgname = pony.computer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bdda2db609a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=pony.computer
+pkgver=1428445028
+pkgrel=1
+pkgdesc="Show computer information and a pony"
+url="https://github.com/GNU-Pony/pony.computer"
+arch=(any)
+license=(GPL3)
+depends=(sh ponysay coreutils python3)
+optdepends=("linux: Additional system information can be provided with Linux kernel's procfs /proc"
+ "filesystem: Identification of distribution"
+ "lsb-release: Identification of distribution")
+makedepends=(make coreutils sed texinfo)
+install=pony.computer.install
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(997f8be119e36cbbdcafee2126ceccfac3e6551d839b78a93aba748f33d4469d)
+
+_prefix=/usr
+
+
+build() {
+ cd "${srcdir}/pony.computer-${pkgver}"
+ make PREFIX="${_prefix}" PKGNAME="${pkgname}" DISTRO="Arch Linux"
+}
+
+package() {
+ cd "${srcdir}/pony.computer-${pkgver}"
+ make PREFIX="${_prefix}" PKGNAME="${pkgname}" DESTDIR="${pkgdir}" install
+ _dir="${pkgdir}${_prefix}/share/licenses/${pkgname}"
+ mkdir -p -- "${_dir}"
+ ln -sf -- "/usr/share/licenses/common/GPL3" "${_dir}/LICENSE"
+}
+
diff --git a/pony.computer.install b/pony.computer.install
new file mode 100644
index 000000000000..2cb5cc3d5e94
--- /dev/null
+++ b/pony.computer.install
@@ -0,0 +1,20 @@
+_file="pony.computer"
+
+infodir="usr/share/info"
+file="${_file}.info"
+
+
+post_install() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info --delete -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+