summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRatakor2023-08-24 09:23:10 -0400
committerRatakor2023-08-24 09:23:10 -0400
commit1584c86901a8a2025b3fc2e3349287a71b6f78b5 (patch)
treee0cc07a81303ac5d62c6fa9e0ebf8980cdd0db88
downloadaur-1584c86901a8a2025b3fc2e3349287a71b6f78b5.tar.gz
Init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..570c91b3c0d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = poop-bin
+ pkgdesc = Performance Optimizer Observation Platform
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/andrewrk/poop
+ arch = x86_64
+ arch = aarch64
+ arch = i686
+ license = MIT
+ provides = poop
+ conflicts = poop
+ source = https://github.com/andrewrk/poop/releases/download/0.4.0/x86_64-linux-poop
+ sha256sums = SKIP
+
+pkgname = poop-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d15dae56d40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Ratakor <ratakor@disroot.org>
+
+pkgname=poop-bin
+_pkgname=${pkgname%-bin}
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Performance Optimizer Observation Platform"
+arch=('x86_64' 'aarch64' 'i686')
+url="https://github.com/andrewrk/$_pkgname"
+license=('MIT')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$url/releases/download/$pkgver/$CARCH-linux-$_pkgname")
+sha256sums=('SKIP')
+
+package() {
+ install -Dm755 "$CARCH-linux-$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+}