summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2021-08-21 12:43:31 +0200
committerChristopher Reimer2021-08-21 12:43:31 +0200
commitb807bf890a2074cc255f7c20159feecca3a7d461 (patch)
tree76997126de675cfad63edcf74b4626855df50c2b
parent93636d4ce98e11f76f08cf6c06a3c3ae2c51c1f3 (diff)
downloadaur-pop-gtk-theme.tar.gz
Update pop-gtk-theme 5.4.4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 8 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5ece6b32567..6384d57022e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pop-gtk-theme
pkgdesc = System76 Pop GTK+ Theme
- pkgver = 5.4.3
+ pkgver = 5.4.4
pkgrel = 1
url = https://github.com/pop-os/gtk-theme
arch = any
@@ -9,7 +9,7 @@ pkgbase = pop-gtk-theme
license = GPL3
makedepends = sassc
makedepends = meson
- source = pop-gtk-theme-489dbc8.tar.gz::https://github.com/pop-os/gtk-theme/archive/489dbc8.tar.gz
- sha512sums = 1e4e3b6a3896b91f068278e5a77d778ace7239a5bd81b7cc667dfe8dc4276abc46fb736aaefbca97a5a3f1cff7540697bbaa3d1125455373e473a0895a144728
+ source = https://github.com/pop-os/gtk-theme/archive/refs/tags/v5.4.4.tar.gz
+ sha512sums = 98aee760f11da91a8a3e2900070ee591b5150e542e967fad17419947607a325b26132b14a25b472f2124d0ad5ef56050de8030e6f1a80cbd8f1361df32fbd64f
pkgname = pop-gtk-theme
diff --git a/PKGBUILD b/PKGBUILD
index 735d391489aa..e7cb4698969d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,24 @@
# Contributor: Carl George < carl at george dot computer >
pkgname=pop-gtk-theme
-_basever=5.4.3
-_timestamp=1629313952
-_commit=489dbc8
-# There are no recent releases on Github. So this package follows the official PPA's releases
-# http://ppa.launchpad.net/system76/pop/ubuntu/pool/main/p/pop-gtk-theme
-#pkgver="${_basever}~${_timestamp}~${_commit}" # Not needed until _basever keeps the same between new releases
-pkgver="${_basever}"
+pkgver=5.4.4
pkgrel=1
pkgdesc="System76 Pop GTK+ Theme"
arch=('any')
url='https://github.com/pop-os/gtk-theme'
license=('LGPL2.1' 'CCPL' 'GPL3')
makedepends=('sassc' 'meson')
-source=("${pkgname}-${_commit}.tar.gz::https://github.com/pop-os/gtk-theme/archive/${_commit}.tar.gz")
-sha512sums=('1e4e3b6a3896b91f068278e5a77d778ace7239a5bd81b7cc667dfe8dc4276abc46fb736aaefbca97a5a3f1cff7540697bbaa3d1125455373e473a0895a144728')
+source=("https://github.com/pop-os/gtk-theme/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('98aee760f11da91a8a3e2900070ee591b5150e542e967fad17419947607a325b26132b14a25b472f2124d0ad5ef56050de8030e6f1a80cbd8f1361df32fbd64f')
build() {
- cd "gtk-theme-${_commit}"*
+ cd "gtk-theme-${pkgver}"
meson --prefix='/usr' build
ninja -C build
}
package() {
- cd "gtk-theme-${_commit}"*
+ cd "gtk-theme-${pkgver}"
DESTDIR="${pkgdir}" ninja -C build install
# https://github.com/pop-os/gtk-theme/issues/436