summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcarlwgeorge2017-05-08 21:39:07 -0500
committercarlwgeorge2017-05-08 21:39:07 -0500
commit0b68fcc47535ef0883800e95c5d43dd0a6a8281a (patch)
treec3c38e372087ff46bc05e210491c8cd7dd1359b7
downloadaur-0b68fcc47535ef0883800e95c5d43dd0a6a8281a.tar.gz
1.0.8-1
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD61
-rw-r--r--fix-chrome-nokto-install.patch19
4 files changed, 127 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5222c1ee922f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+# Generated by mksrcinfo v8
+# Tue May 9 02:38:28 UTC 2017
+pkgbase = pop-gtk-theme
+ pkgdesc = System76 Pop GTK+ Theme (GNOME, Budgie, XFCE, MATE)
+ pkgver = 1.0.8
+ pkgrel = 1
+ url = https://github.com/system76/pop-gtk-theme
+ arch = any
+ license = GPL2
+ license = CCPL:by-sa
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = inkscape
+ makedepends = gdk-pixbuf2>=2.32.2
+ makedepends = glib2>=2.48.0
+ makedepends = librsvg>=2.40.13
+ makedepends = libsass>=3.3.6
+ makedepends = libxml2
+ makedepends = pkg-config
+ makedepends = sassc>=3.3.2
+ makedepends = parallel
+ source = https://launchpad.net/~system76-dev/+archive/ubuntu/stable/+files/system76-pop-gtk-theme_1.0.8.tar.xz
+ source = fix-chrome-nokto-install.patch
+ sha256sums = 8d38e1b64bbe3668103e5abced61135f2c4955848b0cd3df1da52464e6cc3932
+ sha256sums = 11d334221e2fb8edb36d6e5ca50dd0083c12695394a66f61aa7846da5dbfa71c
+
+pkgname = pop-gtk-theme
+ depends = gtk2>=2.24.30
+ depends = gtk3>=3.18.9
+ depends = gdk-pixbuf2>=2.24.30
+ depends = gtk-engine-murrine>=0.98.1
+ optdepends = gnome-shell>=3.18.3: GNOME Shell
+ optdepends = budgie-desktop>=10.2.7: Budgie desktop
+ optdepends = xfdesktop>=4.12.2: XFCE desktop
+ optdepends = mate-desktop>=1.14.0: MATE desktop
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..08717c5ddaf7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+# sources
+*.tar.xz
+
+# build logs
+*-build.log
+*-namcap.log
+*-package.log
+*-prepare.log
+
+# packages
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26fbbdd33acc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Carl George < arch at cgtx dot us >
+
+pkgname='pop-gtk-theme'
+pkgver=1.0.8
+pkgrel=1
+pkgdesc='System76 Pop GTK+ Theme (GNOME, Budgie, XFCE, MATE)'
+arch=('any')
+url='https://github.com/system76/pop-gtk-theme'
+license=('GPL2' 'CCPL:by-sa')
+makedepends=(
+ 'autoconf'
+ 'automake'
+ 'inkscape'
+ 'gdk-pixbuf2>=2.32.2'
+ 'glib2>=2.48.0'
+ 'librsvg>=2.40.13'
+ 'libsass>=3.3.6'
+ 'libxml2'
+ 'pkg-config'
+ 'sassc>=3.3.2'
+ 'parallel'
+)
+source=("https://launchpad.net/~system76-dev/+archive/ubuntu/stable/+files/system76-pop-gtk-theme_$pkgver.tar.xz"
+ 'fix-chrome-nokto-install.patch')
+sha256sums=('8d38e1b64bbe3668103e5abced61135f2c4955848b0cd3df1da52464e6cc3932'
+ '11d334221e2fb8edb36d6e5ca50dd0083c12695394a66f61aa7846da5dbfa71c')
+
+prepare() {
+ patch -p0 -i fix-chrome-nokto-install.patch
+ cd gtk-theme
+ ./autogen.sh \
+ --disable-flashback \
+ --disable-unity \
+ --enable-nokto \
+ --enable-chrome \
+ --enable-plank \
+ --enable-telegram \
+ --enable-parallel
+}
+
+build() {
+ cd gtk-theme
+ make
+}
+
+package() {
+ depends=(
+ 'gtk2>=2.24.30'
+ 'gtk3>=3.18.9'
+ 'gdk-pixbuf2>=2.24.30'
+ 'gtk-engine-murrine>=0.98.1'
+ )
+ optdepends=(
+ 'gnome-shell>=3.18.3: GNOME Shell'
+ 'budgie-desktop>=10.2.7: Budgie desktop'
+ 'xfdesktop>=4.12.2: XFCE desktop'
+ 'mate-desktop>=1.14.0: MATE desktop'
+ )
+ cd gtk-theme
+ make DESTDIR="$pkgdir" install
+}
diff --git a/fix-chrome-nokto-install.patch b/fix-chrome-nokto-install.patch
new file mode 100644
index 000000000000..1079c2af3eda
--- /dev/null
+++ b/fix-chrome-nokto-install.patch
@@ -0,0 +1,19 @@
+diff -Naurp gtk-theme.orig/extra/Makefile.am gtk-theme/extra/Makefile.am
+--- gtk-theme.orig/extra/Makefile.am 2017-04-27 16:26:47.000000000 -0500
++++ gtk-theme/extra/Makefile.am 2017-05-08 21:13:52.053126399 -0500
+@@ -35,7 +35,6 @@ if ENABLE_CHROME
+ $(MKDIR_P) $(adaptadir)/chrome
+
+ cp -Rv $(chrome_file) $(adaptadir)/chrome
+- cp -Rv $(chrome_nokto_file) $(noktodir)/chrome
+
+ cd $(adaptadir)
+ ln -sf ../Pop/chrome $(adaptaetadir)/chrome
+@@ -43,6 +42,7 @@ if ENABLE_CHROME
+
+ if ENABLE_NOKTO
+ $(MKDIR_P) $(noktodir)/chrome
++ cp -Rv $(chrome_nokto_file) $(noktodir)/chrome
+ cd $(adaptadir)
+ ln -sf ../Pop-Nokto/chrome $(noktoetadir)/chrome
+ endif