summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2021-02-07 21:00:12 +0100
committerChristopher Reimer2021-02-07 21:00:12 +0100
commitfbdfe14d6d63d20c3f02c1f79d1192fe142e3dd5 (patch)
treea725fc42ac3a101d66c6feb8a3022f017725f8c0
parent2557b33018b3a417845dddf1bc7ec9960f280d1e (diff)
downloadaur-fbdfe14d6d63d20c3f02c1f79d1192fe142e3dd5.tar.gz
Update version 5.3.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 17 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45f6f688c50c..fa8b28b8f9e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,15 @@
pkgbase = pop-gtk-theme
pkgdesc = System76 Pop GTK+ Theme
- pkgver = 5.3.1
- pkgrel = 2
+ pkgver = 5.3.3
+ pkgrel = 1
url = https://github.com/pop-os/gtk-theme
arch = any
license = LGPL2.1
license = CCPL
license = GPL3
- makedepends = inkscape
makedepends = sassc
- makedepends = optipng
- makedepends = parallel
makedepends = meson
- makedepends = glib2
- makedepends = ninja
- source = pop-gtk-theme-5.3.1.tar.gz::https://github.com/pop-os/gtk-theme/archive/v5.3.1.tar.gz
- sha256sums = 5e51f9b8d0e904d401a434cd0254766d2e461ff0e9d1f09e8b6a02fe030f4763
+ source = pop-gtk-theme-5.3.3.tar.gz::https://github.com/pop-os/gtk-theme/archive/5ab6f1e40aa7067795655cb4d1a1703dc7ce93ca.tar.gz
+ sha512sums = 2433fc9d1e354c3cf36a5dfe311819ab6cb9e801a420709b048e51dea1d8e1d95decb5fa5760d51e82a4de2f06b8674e0cb1ab0c5b906b4ef525e03ea40e4b54
pkgname = pop-gtk-theme
-
diff --git a/PKGBUILD b/PKGBUILD
index d2ab93555301..6418b68463d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,31 @@
-# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Maintainer: Christopher Reimer <mail at c-reimer dot de>
+# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
# Contributor: Dan Beste <dan.ray.beste@gmail.com>
# Contributor: Carl George < carl at george dot computer >
pkgname=pop-gtk-theme
-pkgver=5.3.1
-pkgrel=2
+pkgver=5.3.3
+_commit=5ab6f1e40aa7067795655cb4d1a1703dc7ce93ca
+pkgrel=1
pkgdesc="System76 Pop GTK+ Theme"
arch=('any')
url='https://github.com/pop-os/gtk-theme'
license=('LGPL2.1' 'CCPL' 'GPL3')
-makedepends=('inkscape'
- 'sassc'
- 'optipng'
- 'parallel'
- 'meson'
- 'glib2'
- 'ninja')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/pop-os/gtk-theme/archive/v${pkgver}.tar.gz")
-sha256sums=('5e51f9b8d0e904d401a434cd0254766d2e461ff0e9d1f09e8b6a02fe030f4763')
+makedepends=('sassc' 'meson')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/pop-os/gtk-theme/archive/${_commit}.tar.gz")
+sha512sums=('2433fc9d1e354c3cf36a5dfe311819ab6cb9e801a420709b048e51dea1d8e1d95decb5fa5760d51e82a4de2f06b8674e0cb1ab0c5b906b4ef525e03ea40e4b54')
build() {
- cd "gtk-theme-${pkgver}"
+ cd "gtk-theme-${_commit}"
meson --prefix='/usr' build
ninja -C build
}
package() {
- cd "gtk-theme-${pkgver}"
+ cd "gtk-theme-${_commit}"
DESTDIR="${pkgdir}" ninja -C build install
+
+ # https://github.com/pop-os/gtk-theme/issues/436
ln -s /usr/share/gnome-shell/theme/Pop-dark "${pkgdir}/usr/share/themes/Pop-dark/gnome-shell"
}
-# vim: ts=2 sw=2 et:
+