summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Wallstrom2019-04-27 17:50:54 +0200
committerErik Wallstrom2019-04-27 17:50:54 +0200
commitab1ea548249b12f9b2025461967f06013d679daf (patch)
tree7bee40487eff7546aa7061fb7af578935b7ff8cf
parent5743e125b77ba027c324941495d99b9ea22777b3 (diff)
downloadaur-ab1ea548249b12f9b2025461967f06013d679daf.tar.gz
Updated to work with new repo and build system
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD31
2 files changed, 23 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d30fcecbdb04..58842f1edb00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = pop-icon-theme-git
- pkgdesc = A free and open source SVG icon theme for Linux, based on Paper Icon Set and Papirus.
- pkgver = r2148.b1b46e861
+ pkgdesc = An icon theme for Pop!_OS
+ pkgver = r2326.27be527bda
pkgrel = 1
- url = https://github.com/system76/pop-icon-theme
+ url = https://github.com/pop-os/icon-theme
arch = any
- license = GPL2
license = CCPL
makedepends = git
+ makedepends = meson
+ makedepends = ninja
optdepends = gnome-shell
optdepends = gnome-flashback
optdepends = budgie-desktop
@@ -18,7 +19,7 @@ pkgbase = pop-icon-theme-git
optdepends = pop-shell-theme-git: Recommended shell theme
provides = pop-icon-theme
conflicts = pop-icon-theme
- source = git+https://github.com/system76/pop-icon-theme.git
+ source = pop-icon-theme::git+https://github.com/pop-os/icon-theme.git
sha256sums = SKIP
pkgname = pop-icon-theme-git
diff --git a/PKGBUILD b/PKGBUILD
index d742aa3b38de..f66644845f59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Erik Wallström <erik.wallstrom@live.com>
pkgname=pop-icon-theme-git
_pkgname=pop-icon-theme
-pkgver="r2148.b1b46e861"
+pkgver=r2326.27be527bda
pkgrel=1
-pkgdesc="A free and open source SVG icon theme for Linux, based on Paper Icon Set and Papirus."
+pkgdesc="An icon theme for Pop!_OS"
arch=("any")
-url="https://github.com/system76/pop-icon-theme"
-license=('GPL2' 'CCPL')
-makedepends=("git")
+url="https://github.com/pop-os/icon-theme"
+license=('CCPL')
+makedepends=("git" "meson" "ninja")
optdepends=(
"gnome-shell"
"gnome-flashback"
@@ -21,18 +21,21 @@ optdepends=(
)
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("git+https://github.com/system76/pop-icon-theme.git")
+source=("${_pkgname}::git+https://github.com/pop-os/icon-theme.git")
sha256sums=("SKIP")
-#build() { }
+pkgver() {
+ cd ${srcdir}/${_pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
-package() {
- cd "${_pkgname}"
- make DESTDIR="${pkgdir}" install
- make DESTDIR="${pkgdir}" post-install
+build() {
+ cd ${srcdir}/${_pkgname}
+ meson --prefix='/usr' build
+ ninja -C build
}
-pkgver() {
- cd "${_pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+package() {
+ cd ${srcdir}/${_pkgname}
+ DESTDIR="${pkgdir}" ninja -C build install
}