summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-03-29 11:02:31 -0600
committerMark Wagie2022-03-29 11:02:31 -0600
commit0fa11632ec73a456758be34e31c837ff8762426d (patch)
tree9534cb57e7609f14a5fab33a0c2877f48800a258
parent657f39f7d03523101e4ee0ade30e3bf61c09ee58 (diff)
downloadaur-0fa11632ec73a456758be34e31c837ff8762426d.tar.gz
adapt to upstream build changes
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2824cf59fa8..625a161bff50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = pop-launcher-git
- pkgver = 1.1.0.r8.g1d031d9
+ pkgver = 1.2.0.r0.gbacada0
pkgrel = 1
url = https://github.com/pop-os/launcher
arch = x86_64
@@ -7,6 +7,7 @@ pkgbase = pop-launcher-git
license = MPL2
makedepends = cargo
makedepends = git
+ makedepends = just
depends = fd
depends = gtk3
depends = libqalculate
diff --git a/PKGBUILD b/PKGBUILD
index 525eef133195..a7ff4777b872 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=('pop-launcher-git' 'pop-shell-plugin-system76-power-git')
pkgbase=pop-launcher-git
-pkgver=1.1.0.r8.g1d031d9
+pkgver=1.2.0.r0.gbacada0
pkgrel=1
arch=('x86_64' 'aarch64')
url="https://github.com/pop-os/launcher"
license=('MPL2')
depends=('fd' 'gtk3' 'libqalculate')
-makedepends=('cargo' 'git')
+makedepends=('cargo' 'git' 'just')
options=('!lto')
source=('git+https://github.com/pop-os/launcher.git')
sha256sums=('SKIP')
@@ -21,12 +21,14 @@ prepare() {
cd "$srcdir/launcher"
export RUSTUP_TOOLCHAIN=stable
cargo fetch --target "$CARCH-unknown-linux-gnu"
+
+ sed -i 's|{{bin_path}}|/usr/bin/pop-launcher|g' justfile
}
build() {
cd "$srcdir/launcher"
export RUSTUP_TOOLCHAIN=stable
- make
+ just
}
package_pop-launcher-git() {
@@ -36,11 +38,11 @@ package_pop-launcher-git() {
conflicts=("${pkgname%-git}")
cd "$srcdir/launcher"
- sed -i "s|${pkgbase%-git}-bin \$(BIN)|${pkgbase%-git}-bin $pkgdir/usr/bin/${pkgbase%-git}|g" Makefile
+ install -Dm755 "target/release/${pkgname%-git}-bin" "$pkgdir/usr/bin/${pkgname%-git}"
- make BIN="/usr/bin/${pkgbase%-git}" DESTDIR="$pkgdir/" install
+ just rootdir="$pkgdir" install_plugins install_scripts
- rm -rf "$pkgdir/usr/lib/${pkgbase%-git}/scripts/system76-power"
+ rm -rf "$pkgdir/usr/lib/${pkgname%-git}/scripts/system76-power"
}
package_pop-shell-plugin-system76-power-git() {