summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-02-08 10:19:04 -0700
committerMark Wagie2023-02-08 10:19:04 -0700
commit3ab838f27dbc5ec6f86f078c8f1ddeab9c100368 (patch)
treee54349a04c8a7dc5b366cb76ed9ae8e1e08eb058
parentfaa9f57a757618ea99ef0799a3c616afa511f6c4 (diff)
downloadaur-3ab838f27dbc5ec6f86f078c8f1ddeab9c100368.tar.gz
update deps, adjust to justfile changes, add check
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 677de81229c0..72af184d342b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = pop-launcher-git
- pkgver = 1.2.1.r0.g0893990
+ pkgver = 1.2.1.r43.gf8ec5b8
pkgrel = 1
url = https://github.com/pop-os/launcher
arch = x86_64
@@ -8,9 +8,12 @@ pkgbase = pop-launcher-git
makedepends = cargo
makedepends = git
makedepends = just
+ makedepends = libglvnd
+ makedepends = libxkbcommon
depends = fd
depends = libqalculate
depends = sh
+ depends = xdg-utils
options = !lto
source = git+https://github.com/pop-os/launcher.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3181084e4bb0..2b9efcc634dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=('pop-launcher-git' 'pop-shell-plugin-system76-power-git')
pkgbase=pop-launcher-git
-pkgver=1.2.1.r0.g0893990
+pkgver=1.2.1.r43.gf8ec5b8
pkgrel=1
arch=('x86_64' 'aarch64')
url="https://github.com/pop-os/launcher"
license=('MPL2')
-depends=('fd' 'libqalculate' 'sh')
-makedepends=('cargo' 'git' 'just')
+depends=('fd' 'libqalculate' 'sh' 'xdg-utils')
+makedepends=('cargo' 'git' 'just' 'libglvnd' 'libxkbcommon')
options=('!lto')
source=('git+https://github.com/pop-os/launcher.git')
sha256sums=('SKIP')
@@ -20,17 +20,21 @@ pkgver() {
prepare() {
cd "$srcdir/launcher"
export RUSTUP_TOOLCHAIN=stable
- cargo fetch --target "$CARCH-unknown-linux-gnu"
-
just vendor
- sed -i 's|{{bin_path}}|/usr/bin/pop-launcher|g' justfile
+ sed -i 's|{{bin-path}}|/usr/bin/pop-launcher|g' justfile
}
build() {
cd "$srcdir/launcher"
export RUSTUP_TOOLCHAIN=stable
- just vendor=1
+ just build-vendored
+}
+
+check() {
+ cd "$srcdir/launcher"
+ export RUSTUP_TOOLCHAIN=stable
+ just check
}
package_pop-launcher-git() {
@@ -42,7 +46,7 @@ package_pop-launcher-git() {
cd "$srcdir/launcher"
install -Dm755 "target/release/${pkgname%-git}-bin" "$pkgdir/usr/bin/${pkgname%-git}"
- just rootdir="$pkgdir" install_plugins install_scripts
+ just rootdir="$pkgdir" install-plugins install-scripts
rm -rf "$pkgdir/usr/lib/${pkgname%-git}/scripts/system76-power"
}