summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-09-28 09:01:43 -0600
committerMark Wagie2020-09-28 09:01:43 -0600
commitd54d31c949ba267f1218939b191b28691388e921 (patch)
tree25e91eb56c3403d9ad099a6eb5a7927c07294a92
parentf7de6bfc368b93fe5aa53f99275080f1366369d1 (diff)
downloadaur-d54d31c949ba267f1218939b191b28691388e921.tar.gz
fix install prefix
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD43
3 files changed, 30 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4eeb9045040f..f898092d3c02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = pop-shell-shortcuts-git
pkgdesc = Application for displaying and demoing Pop Shell shortcuts
- pkgver = r25.ada2c50
+ pkgver = r37.9280535
pkgrel = 1
url = https://github.com/pop-os/shell-shortcuts
- arch = any
- license = GPLv3
+ arch = x86_64
+ license = GPL
+ makedepends = git
makedepends = rust
- depends = cairo
- depends = pango
- depends = atk
- depends = gdk-pixbuf2
- depends = gtk3
+ depends = gnome-shell
+ provides = pop-shell-shortcuts
conflicts = pop-shell-shortcuts
- source = shell-shortcuts::git+https://github.com/pop-os/shell-shortcuts.git#branch=master_focal
+ source = git+https://github.com/pop-os/shell-shortcuts.git
sha256sums = SKIP
pkgname = pop-shell-shortcuts-git
diff --git a/.gitignore b/.gitignore
index fa50cb388a14..4dab8d6386e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,7 @@
-*.tar.gz
-*.pkg.tar.xz
-pkg/
-src/
-shell-shortcuts/
+# Ignore everything
+*
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index cf4f1b7baeed..11aa84851395 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,31 @@
-# Maintainer: ftsell <aur@finn-thorben.me>
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: ftsell <aur@finn-thorben.me>
pkgname=pop-shell-shortcuts-git
-pkgdesc="Application for displaying and demoing Pop Shell shortcuts "
-pkgver=r25.ada2c50
+pkgver=r37.9280535
pkgrel=1
-_gitorg=pop-os
-_gitname=shell-shortcuts
-_gitbranch=master_focal
-arch=(any)
+pkgdesc="Application for displaying and demoing Pop Shell shortcuts"
+arch=('x86_64')
url="https://github.com/pop-os/shell-shortcuts"
-license=("GPLv3")
-
-conflicts=("pop-shell-shortcuts")
-makedepends=("rust")
-depends=("cairo" "pango" "atk" "gdk-pixbuf2" "gtk3")
-
-
-_dir="${_gitname}"
-source=("${_dir}::git+https://github.com/${_gitorg}/${_gitname}.git#branch=${_gitbranch}")
-sha256sums=("SKIP")
-
+license=('GPL')
+depends=('gnome-shell')
+makedepends=('git' 'rust')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/pop-os/shell-shortcuts.git')
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_dir}"
+ cd "$srcdir/shell-shortcuts"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-
build() {
- cd "${srcdir}/${_dir}"
- make update
- make all
+ cd "$srcdir/shell-shortcuts"
+ make prefix=/usr
}
-
package() {
- cd "${srcdir}/${_dir}"
- make DESTDIR="${pkgdir}/" install
+ cd "$srcdir/shell-shortcuts"
+ make prefix=/usr DESTDIR="$pkgdir" install
}