summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFinn-Thorben Sell2020-05-02 18:36:10 +0200
committerFinn-Thorben Sell2020-05-02 18:36:10 +0200
commitf07c839e37c26d66157549660c9ca43b041d8e83 (patch)
treed9e30bf3699c4e58b4f94a0c12e8db04152a3ed0
downloadaur-f07c839e37c26d66157549660c9ca43b041d8e83.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rwxr-xr-x.gitignore6
-rwxr-xr-xPKGBUILD40
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4feca7ab87ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pop-shell-shortcuts-git
+ pkgdesc = Application for displaying and demoing Pop Shell shortcuts
+ pkgver = r25.ada2c50
+ pkgrel = 1
+ url = https://github.com/pop-os/shell-shortcuts
+ arch = any
+ license = GPLv3
+ makedepends = rust
+ depends = cairo
+ depends = glib
+ depends = pango
+ depends = atk
+ depends = gdk-pixbuf2
+ depends = gtk3
+ conflicts = pop-shell-shortcuts
+ source = shell-shortcuts::git+https://github.com/pop-os/shell-shortcuts.git#branch=master_focal
+ sha256sums = SKIP
+
+pkgname = pop-shell-shortcuts-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100755
index 000000000000..fa50cb388a14
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.pkg.tar.xz
+pkg/
+src/
+shell-shortcuts/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..1bdf11f89894
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: ftsell <aur@finn-thorben.me>
+pkgname=pop-shell-shortcuts-git
+pkgdesc="Application for displaying and demoing Pop Shell shortcuts "
+pkgver=r25.ada2c50
+pkgrel=1
+_gitorg=pop-os
+_gitname=shell-shortcuts
+_gitbranch=master_focal
+arch=(any)
+url="https://github.com/pop-os/shell-shortcuts"
+license=("GPLv3")
+
+conflicts=("pop-shell-shortcuts")
+makedepends=("rust")
+depends=("cairo" "glib" "pango" "atk" "gdk-pixbuf2" "gtk3")
+
+
+_dir="${_gitname}"
+source=("${_dir}::git+https://github.com/${_gitorg}/${_gitname}.git#branch=${_gitbranch}")
+sha256sums=("SKIP")
+
+
+pkgver() {
+ cd "${srcdir}/${_dir}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "${srcdir}/${_dir}"
+ make update
+ make all
+}
+
+
+package() {
+ cd "${srcdir}/${_dir}"
+ make DESTDIR="${pkgdir}/" install
+}
+