summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2015-07-30 19:18:57 +0300
committervlad2015-07-30 19:18:57 +0300
commit20507b3f7bf3c9322a111f431026aeb930ba78e1 (patch)
tree0a668b6ef3da8ae5e21a40af2ca62c839e137d59
parent8b9260a120f652c0e097822df51e558d111c32d7 (diff)
downloadaur-20507b3f7bf3c9322a111f431026aeb930ba78e1.tar.gz
Fixes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 6 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a2f4ad6ce93..e76016ac96b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = popcorntime
pkgdesc = Stream movies from torrents. Skip the downloads. Launch, click, watch.
pkgver = 0.3.8.0
- pkgrel = 5
+ pkgrel = 6
url = http://popcorntime.io/
install = popcorntime.install
arch = i686
@@ -24,11 +24,9 @@ pkgbase = popcorntime
options = !strip
source = desktop-v0.3.8-0.tar.bz2::https://git.popcorntime.io/popcorntime/desktop/repository/archive.tar.bz2?ref=v0.3.8-0
source = desktop-i18n-master.tar.bz2::https://git.popcorntime.io/popcorntime/desktop-i18n/repository/archive.tar.bz2?ref=master
- source = http://dl.nwjs.io/v0.12.1/nwjs-v0.12.1-linux-x64.tar.gz
source = popcorntime.desktop
sha256sums = 58e903cdbed2eb6f7784b38ce847f3fff6315034f58adc806c7a50d0cd763c9c
sha256sums = SKIP
- sha256sums = 7f46d6c00fd2bb3aae70e177b94685af2f53476c3ee50c1c243760d0f271b505
sha256sums = f89595aeaf1c09ad2b0a869be1ad14922b4747f901cec0f1b65c4c72719dcdec
pkgname = popcorntime
diff --git a/PKGBUILD b/PKGBUILD
index 6240715972d9..3fd00d7e5c8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=popcorntime
pkgver=0.3.8.0
_pkgver=0.3.8-0
-pkgrel=5
+pkgrel=6
pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch."
arch=('i686' 'x86_64')
url="http://popcorntime.io/"
@@ -25,9 +25,7 @@ depends=('alsa-lib'
'libxtst'
'nss'
'ttf-font')
-optdepends=('net-tools: vpn.ht client'
- 'ttf-liberation'
- 'ttf-ms-fonts')
+optdepends=('net-tools: vpn.ht client')
options=('!strip')
install="popcorntime.install"
_gitname=desktop.git
@@ -43,25 +41,18 @@ fi
source=("desktop-v${_pkgver}.tar.bz2::https://git.popcorntime.io/popcorntime/desktop/repository/archive.tar.bz2?ref=v${_pkgver}"
"desktop-i18n-master.tar.bz2::https://git.popcorntime.io/popcorntime/desktop-i18n/repository/archive.tar.bz2?ref=master"
- "http://dl.nwjs.io/v${_nw_ver}/nwjs-v${_nw_ver}-${_nw_platform}.tar.gz"
"popcorntime.desktop")
sha256sums=('58e903cdbed2eb6f7784b38ce847f3fff6315034f58adc806c7a50d0cd763c9c'
'SKIP'
- '7f46d6c00fd2bb3aae70e177b94685af2f53476c3ee50c1c243760d0f271b505'
'f89595aeaf1c09ad2b0a869be1ad14922b4747f901cec0f1b65c4c72719dcdec')
prepare() {
cd "${srcdir}/${_gitname}"
- # https://git.popcorntime.io/popcorntime/desktop/commit/6f1864cb00b0af4da062391de04206f9495c88b0
- sed -i "s|git+https://git.popcorntime.io/mirrors/peerflix.git|https://git.popcorntime.io/mirrors/peerflix/repository/archive.tar.gz|g" package.json
+ sed -i "s|opensubtitles.git|opensubtitles-api.git|g" package.json
cp "${srcdir}"/desktop-i18n.git/* src/app/language
- mkdir -p "${srcdir}/${_gitname}/build/cache/${_platform}/${_nw_ver}/"
- mv "${srcdir}/nwjs-v${_nw_ver}-${_nw_platform}/"* \
- "${srcdir}/${_gitname}/build/cache/${_platform}/${_nw_ver}/"
-
# for gyp
export PYTHON=/usr/bin/python2
@@ -72,10 +63,10 @@ prepare() {
build() {
cd "${srcdir}/${_gitname}"
- # The grunt 'build' task served as a reference for this:
grunt css
grunt bower_clean
- grunt nodewebkit
+ # Fatal error: Cannot read property 'length' of undefined
+ grunt nodewebkit || grunt nodewebkit
}
package() {