summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2017-05-24 17:12:05 +0200
committerGiovanni Santini2017-05-24 17:12:05 +0200
commit46fd12681eaafe603351dc7f75088bd74601a728 (patch)
tree80ad46efdbf4e49ccf3707a046e4b711dbf0c5a3
parentb5a12d6cce87a0beb2d0f6db5b2a5477997acba2 (diff)
downloadaur-46fd12681eaafe603351dc7f75088bd74601a728.tar.gz
upgpkg: popcorntime 0.3.10-2
- Avoid security issue caused by subtitles - Fix broken build caused by the module 'thepiratebay'
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e5fde3e1738..03c52b338dfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 1 20:18:39 UTC 2016
+# Wed May 24 15:12:05 UTC 2017
pkgbase = popcorntime
pkgdesc = Stream movies from torrents. Skip the downloads. Launch, click, watch.
pkgver = 0.3.10
- pkgrel = 1
+ pkgrel = 2
url = http://popcorntime.sh/
arch = i686
arch = x86_64
@@ -22,7 +22,7 @@ pkgbase = popcorntime
depends = ttf-font
optdepends = net-tools: vpn.ht client
options = !strip
- source = popcorn-desktop_0.3.10::git+https://github.com/popcorn-official/popcorn-desktop/#tag=0.3.10
+ source = popcorn-desktop_0.3.10::git+https://github.com/popcorn-official/popcorn-desktop/#commit=9e25e9f004bcab070cdecb201ba89da539b2f780
source = popcorntime.desktop
sha256sums = SKIP
sha256sums = 4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334
diff --git a/PKGBUILD b/PKGBUILD
index 415a99d3a15c..36ea48727eef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=popcorntime
pkgver=0.3.10
-pkgrel=1
+pkgrel=2
pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch."
arch=('i686' 'x86_64')
url="http://popcorntime.sh/"
@@ -34,7 +34,7 @@ optdepends=('net-tools: vpn.ht client')
options=('!strip')
#install="popcorntime.install"
# Needed variables for sources downloads
-_commit_hash="tag=0.3.10"
+_commit_hash="commit=9e25e9f004bcab070cdecb201ba89da539b2f780"
_pkgname="popcorn-desktop"
source=(
@@ -54,13 +54,24 @@ _bpath="${_srcdir}/build/Popcorn-Time/${_platform}"
prepare() {
cd "${srcdir}/${_srcdir}"
- msg2 "Installing npm and bower dependencies..."
+ msg2 "Installing npm, bower and missing dependencies..."
# Using a different folder for the cache, makes the system cleaner
_cache=`npm config get cache`
npm config set cache "$srcdir/npm_cache"
+ msg2 "Cache changed from $_cache to `npm config get cache`"
+
+ msg2 "Install missing dependencies"
+ missing_ones="thepiratebay@1.4.0"
+ for package in $missing_ones
+ do
+ msg2 "Installing missing dependency $package"
+ npm install "$package"
+ done
+
# Actually install the stuff
- msg2 "Cache changed from $_cache to `npm config get cache`, ready to install"
+ msg2 "Installing normal dependencies"
npm install #-dd install
+
# Restore the cache directory
npm config set cache ${_cache}
}