summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2018-05-12 16:18:18 +0200
committerGiovanni Santini2018-05-12 16:18:18 +0200
commitb8adad6d72a3f5b267bd88bdddb9eeacc76304a5 (patch)
tree74e31948f27d505dbe217ae0b1316c4228f35d6c
parente5088b0517fb1123a987988e6b74cf9ce3f7aecd (diff)
downloadaur-b8adad6d72a3f5b267bd88bdddb9eeacc76304a5.tar.gz
upgpkg: popcorntime 0.3.10-6
- Better npm cache handling - VODO provider is updated upstream now
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1924f20d6533..2d2bed1aab97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = popcorntime
pkgdesc = Stream movies from torrents. Skip the downloads. Launch, click, watch.
pkgver = 0.3.10
- pkgrel = 5
+ pkgrel = 6
url = http://popcorntime.sh/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 78f7b2dc29ef..00f3293788f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=popcorntime
pkgver=0.3.10
-pkgrel=5
+pkgrel=6
pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch."
arch=('i686' 'x86_64')
url="http://popcorntime.sh/"
@@ -43,8 +43,10 @@ prepare() {
msg2 "Installing npm, bower and missing dependencies..."
# Using a different folder for the cache, makes the system cleaner
- _cache=`npm config get cache`
- npm config set cache "$srcdir/npm_cache"
+ #_cache=`npm config get cache`
+ #npm config set cache "$srcdir/npm_cache"
+ # Thanks to Eschwartz for the tip!
+ export npm_config_cache="$srcdir/npm_cache"
msg2 "Cache changed from $_cache to `npm config get cache`"
msg2 "Install missing dependencies, if any"
@@ -63,14 +65,14 @@ prepare() {
msg "Patching Vodo provider (butter-provider-vodo)..."
# Obviously, when I try to update Node software, some dev makes big updates.
# These are from less than a week ago; just fetch the old working version
- sed -E 's|(.*vodo.*)",|\1#f61e70217711b4a29ff50618d28e8d4170d63fe5",|' -i package.json
+ #sed -E 's|(.*vodo.*)",|\1#f61e70217711b4a29ff50618d28e8d4170d63fe5",|' -i package.json
# Actually install the stuff
msg2 "Installing normal dependencies"
npm install #-dd install
# Restore the cache directory
- npm config set cache ${_cache}
+ #npm config set cache ${_cache}
}
build() {