summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKostis Karantias2018-12-16 21:09:39 +0200
committerKostis Karantias2018-12-16 21:09:39 +0200
commit4d8b7a1f13f15555e79e48559dc719d9cc729ba0 (patch)
tree66cf098d6dd578864786841109ee3c58111dcebb
parent2bca99a4327fe051b31d5312787e5ed67bd6f3ec (diff)
downloadaur-4d8b7a1f13f15555e79e48559dc719d9cc729ba0.tar.gz
Make this explicitly a CI build
* Rename with -ci- * Build # as pkgrel and in URL so that our source urls are valid forever * Include checksums
-rw-r--r--PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index caa39f5167c9..699d3a1cec0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Pieter Goetschalckx <3.14.e.ter [at] gmail [dot] com>
+# Maintainer: Kostis Karantias <kkarantias [at] gmail [dot] com>
+# Contributor: Pieter Goetschalckx <3.14.e.ter [at] gmail [dot] com>
# Contributor: Bastien Traverse <firstname at lastname dot email>
# Contributor: Ricardo Funke <ricardo [at] gmail [dot] com>
# Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu>
@@ -11,27 +12,24 @@
# Contributor: xantares <xantares09 [at] hotmail [dot] com>
# Contributor: petterk <stifler3k [at] hotmail [dot] com>
-pkgname=popcorntime-bin
+pkgname=popcorntime-ci-bin
_pkgname=popcorntime
pkgver=0.3.10
-pkgrel=3
+pkgrel=362
pkgdesc="Stream movies and TV shows from torrents (continuous integration builds)"
arch=('i686' 'x86_64')
url="https://popcorntime.sh"
license=('GPL3')
depends=('alsa-lib' 'gconf' 'gtk2' 'nss' 'ttf-font' 'libxtst' 'libnotify' 'desktop-file-utils')
-provides=('popcorntime' 'popcorn-time-ce')
+provides=('popcorntime' 'popcorn-time-ce' 'popcorntime-bin')
conflicts=('popcorntime')
options=('!strip')
source=("${_pkgname}.desktop")
-## Official releases are lagging behind. Using CI builds instead
-#source_i686=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-32.tar.xz")
-#source_x86_64=("https://get.popcorntime.sh/repo/build/Popcorn-Time-${pkgver}-Linux-64.tar.xz")
-source_i686=("https://ci.popcorntime.sh/job/Popcorn-Time-Desktop/lastSuccessfulBuild/artifact/build/Popcorn-Time-${pkgver}_linux32.tar.xz")
-source_x86_64=("https://ci.popcorntime.sh/job/Popcorn-Time-Desktop/lastSuccessfulBuild/artifact/build/Popcorn-Time-${pkgver}_linux64.tar.xz")
-sha256sums=('4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334')
-sha256sums_i686=('SKIP')
-sha256sums_x86_64=('SKIP')
+source_i686=("https://ci.popcorntime.sh/job/Popcorn-Time-Desktop/${pkgrel}/artifact/build/Popcorn-Time-${pkgver}_linux32.tar.xz")
+source_x86_64=("https://ci.popcorntime.sh/job/Popcorn-Time-Desktop/${pkgrel}/artifact/build/Popcorn-Time-${pkgver}_linux64.tar.xz")
+sha512sums=('7e6538a7b39465439a62cb089510b6d85a65ad4bfa74d21b692363d1176ee94165ab7b5fef5f3470bf821cfc9f3b3a23763b8e3d8530420d7fa97c66083c3adb')
+sha512sums_i686=('5b6b9ba1232e6bdd3d7b8a949115d0020cf0fed9e2ed3d9d657c9c1a4230ec43ab25a7030d3dbc25b069ab6758bcc73bc659b8a232ad17a70cba7cb801bb374e')
+sha512sums_x86_64=('4995da3263738fd9c99ad9158d13d768627a132253afe9f42d59c6ff6fc90d4ab1569b95b7c9f342b2a09145908af7baac0755d71542b1a5a98c0bbd80ff916a')
package() {
install -dm755 "${pkgdir}/usr/share/${_pkgname}"