summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2016-04-16 02:19:20 +0200
committergrufo2016-04-16 02:19:20 +0200
commit0cb4b68f74ed9f846278fc531990f75cab84c510 (patch)
tree2a68bbf8e36982f0fa5b589c0a2aeeec32134b8a
parent8a0d4e9d058b48497affdbfee18b4c4f20b56af4 (diff)
downloadaur-0cb4b68f74ed9f846278fc531990f75cab84c510.tar.gz
Instructions moved to function "prepare()"
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 379cc79604b8..44998ca9a942 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,7 +26,7 @@ _execname="Popcorn-Time-CE"
_reldir="desktop-${pkgver}-${pkgrel}"
_bindir="${_reldir}/build/${_execname}/${_platform}"
-build() {
+prepare() {
cd "${srcdir}/${_reldir}"
@@ -35,6 +35,12 @@ build() {
# Remove all references to ${srcdir}
find "${srcdir}/${_reldir}" -type f -print0 | xargs -0 sed -i "s|${srcdir}/${_reldir}|/usr/share/${pkgname}|g"
+}
+
+build() {
+
+ cd "${srcdir}/${_reldir}"
+
"${srcdir}/${_reldir}/node_modules/.bin/gulp" build -p ${_platform}
}