summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2017-04-11 21:18:29 +0200
committergrufo2017-04-11 21:18:29 +0200
commit5f161c09d2d5ca32fd89d938dbef6eeca4d411c5 (patch)
tree6fc19eb019f14b9612334839b869bec5093ba8da
parentf4e5a228f824c58218846070cfa0195903ce32f8 (diff)
downloadaur-5f161c09d2d5ca32fd89d938dbef6eeca4d411c5.tar.gz
url http://popcorntime.ag/ changed to http://www.popcorn-time.is/
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD52
-rw-r--r--r306.a576c24.patch30
3 files changed, 43 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a68737f7057a..01746db0b8ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = popcorntime-ce
pkgdesc = Stream movies from torrents. Skip the downloads. Launch, click, watch. Repos of the original community edition.
pkgver = 0.4.1
pkgrel = 5
- url = http://popcorntime.ag/
+ url = http://www.popcorn-time.is/
install = popcorntime-ce.install
arch = x86_64
arch = i686
@@ -29,10 +29,10 @@ pkgbase = popcorntime-ce
source = popcorntime-ce.install
source = popcorntime-ce.desktop
source = r306.a576c24.patch
- sha1sums = 9c376b5b4477ea29112c5217a01eb63932c60f22
- sha1sums = 2c22a3f1d1335abe8d7ac7dd6a33933720ba30e4
- sha1sums = 219a9c7033361e1286967452868721302b1d6da7
- sha1sums = dd94d1fcbde2ee46a58646268c5e962508ef5484
+ md5sums = 6e4d2a73e1a5c2acbc368540c6923300
+ md5sums = b8996810c9862bd9b41880b82055073f
+ md5sums = 53367e600bad6229b200ed4478f8fcbb
+ md5sums = 1913fd025078c54891b2e8a5b1759d0e
pkgname = popcorntime-ce
diff --git a/PKGBUILD b/PKGBUILD
index af59703a0b6f..b8c28bc6e5bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,37 @@
# Maintainer: grufo <madmurphy333@gmail.com>
-pkgname="popcorntime-ce"
-pkgver="0.4.1"
-pkgrel="5"
-pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch. Repos of the original community edition."
-arch=("x86_64" "i686")
-url="http://popcorntime.ag/"
-license=("GPL3")
-depends=("alsa-lib" "desktop-file-utils" "gconf" "gtk2" "libnotify" "libxtst" "nodejs" "nss" "python" "ttf-font")
-makedepends=("npm")
-optdepends=("net-tools: necessary for the new vpn feature" "ttf-liberation: open source ttf fonts")
-provides=("popcorntime" "popcorntime-ce")
-conflicts=("popcorntime-ce-bin" "popcorntime-ce-git")
-options=("!strip")
-install="popcorntime-ce.install"
+pkgname='popcorntime-ce'
+pkgver='0.4.1'
+pkgrel='5'
+pkgdesc='Stream movies from torrents. Skip the downloads. Launch, click, watch. Repos of the original community edition.'
+arch=('x86_64' 'i686')
+url='http://www.popcorn-time.is/'
+license=('GPL3')
+depends=('alsa-lib' 'desktop-file-utils' 'gconf' 'gtk2' 'libnotify' 'libxtst' 'nodejs' 'nss' 'python' 'ttf-font')
+makedepends=('npm')
+optdepends=('net-tools: necessary for the new vpn feature' 'ttf-liberation: open source ttf fonts')
+provides=('popcorntime' 'popcorntime-ce')
+conflicts=('popcorntime-ce-bin' 'popcorntime-ce-git')
+options=('!strip')
+install='popcorntime-ce.install'
source=("https://github.com/PopcornTimeCommunity/desktop/archive/${pkgver}-${pkgrel}.tar.gz"
- "popcorntime-ce.install"
- "popcorntime-ce.desktop"
- "r306.a576c24.patch")
-sha1sums=("9c376b5b4477ea29112c5217a01eb63932c60f22"
- "2c22a3f1d1335abe8d7ac7dd6a33933720ba30e4"
- "219a9c7033361e1286967452868721302b1d6da7"
- "dd94d1fcbde2ee46a58646268c5e962508ef5484")
-
-_platform=$([ $CARCH = "x86_64" ] && echo "linux64" || echo "linux32")
-_execname="Popcorn-Time-CE"
+ 'popcorntime-ce.install'
+ 'popcorntime-ce.desktop'
+ 'r306.a576c24.patch')
+md5sums=('6e4d2a73e1a5c2acbc368540c6923300'
+ 'b8996810c9862bd9b41880b82055073f'
+ '53367e600bad6229b200ed4478f8fcbb'
+ '1913fd025078c54891b2e8a5b1759d0e')
+
+_platform=$([ $CARCH = 'x86_64' ] && echo 'linux64' || echo 'linux32')
+_execname='Popcorn-Time-CE'
_reldir="desktop-${pkgver}-${pkgrel}"
_bindir="${_reldir}/build/${_execname}/${_platform}"
prepare() {
- # Synchronize with commit `a576c24` (bugs solving)
- patch -p1 < "${srcdir}/r306.a576c24.patch"
+ # Synchronize with commit `r306.a576c24` (bug-solving)
+ patch -p0 < "${srcdir}/r306.a576c24.patch"
# Prepare
cd "${srcdir}/${_reldir}"
diff --git a/r306.a576c24.patch b/r306.a576c24.patch
index a6bf3085ce99..38e9eb13f09b 100644
--- a/r306.a576c24.patch
+++ b/r306.a576c24.patch
@@ -1,6 +1,5 @@
-diff -Naur src/desktop-0.4.1-5/package.json src/desktop-0.4.1-5/package.json
---- src/desktop-0.4.1-5/package.json
-+++ src/desktop-0.4.1-5/package.json
+--- desktop-0.4.1-5/package.json
++++ desktop-0.4.1-5/package.json
@@ -7,7 +7,7 @@
"url": "https://github.com/PopcornTimeCommunity/desktop.git"
},
@@ -10,9 +9,8 @@ diff -Naur src/desktop-0.4.1-5/package.json src/desktop-0.4.1-5/package.json
"version": "0.4.1-5",
"node-remote": "*://*",
"releaseName": "New Year's Eve in front of the door",
-diff -Naur src/desktop-0.4.1-5/src/app/lib/providers/trakttv.js src/desktop-0.4.1-5/src/app/lib/providers/trakttv.js
---- src/desktop-0.4.1-5/src/app/lib/providers/trakttv.js
-+++ src/desktop-0.4.1-5/src/app/lib/providers/trakttv.js
+--- desktop-0.4.1-5/src/app/lib/providers/trakttv.js
++++ desktop-0.4.1-5/src/app/lib/providers/trakttv.js
@@ -1,4 +1,4 @@
-(function (App) {
+(function(App) {
@@ -708,9 +706,8 @@ diff -Naur src/desktop-0.4.1-5/src/app/lib/providers/trakttv.js src/desktop-0.4.
-})(window.App);
+})(window.App);
\ No newline at end of file
-diff -Naur src/desktop-0.4.1-5/src/app/lib/views/plugins.js src/desktop-0.4.1-5/src/app/lib/views/plugins.js
---- src/desktop-0.4.1-5/src/app/lib/views/plugins.js
-+++ src/desktop-0.4.1-5/src/app/lib/views/plugins.js
+--- desktop-0.4.1-5/src/app/lib/views/plugins.js
++++ desktop-0.4.1-5/src/app/lib/views/plugins.js
@@ -1,4 +1,4 @@
-(function (App) {
+(function(App) {
@@ -1067,9 +1064,8 @@ diff -Naur src/desktop-0.4.1-5/src/app/lib/views/plugins.js src/desktop-0.4.1-5/
-})(window.App);
+})(window.App);
\ No newline at end of file
-diff -Naur src/desktop-0.4.1-5/src/app/templates/about.tpl src/desktop-0.4.1-5/src/app/templates/about.tpl
---- src/desktop-0.4.1-5/src/app/templates/about.tpl
-+++ src/desktop-0.4.1-5/src/app/templates/about.tpl
+--- desktop-0.4.1-5/src/app/templates/about.tpl
++++ desktop-0.4.1-5/src/app/templates/about.tpl
@@ -2,7 +2,7 @@
<div class="fa fa-times close-icon"></div>
<div class="overlay-content"></div>
@@ -1087,9 +1083,8 @@ diff -Naur src/desktop-0.4.1-5/src/app/templates/about.tpl src/desktop-0.4.1-5/s
+ <div class="changelog-text"></div>
</div>
</div>
-diff -Naur src/desktop-0.4.1-5/src/app/templates/disclaimer.tpl src/desktop-0.4.1-5/src/app/templates/disclaimer.tpl
---- src/desktop-0.4.1-5/src/app/templates/disclaimer.tpl
-+++ src/desktop-0.4.1-5/src/app/templates/disclaimer.tpl
+--- desktop-0.4.1-5/src/app/templates/disclaimer.tpl
++++ desktop-0.4.1-5/src/app/templates/disclaimer.tpl
@@ -1,6 +1,6 @@
<div class="loading-background"></div>
<div class="disclaimer-loading"></div>
@@ -1129,9 +1124,8 @@ diff -Naur src/desktop-0.4.1-5/src/app/templates/disclaimer.tpl src/desktop-0.4.
-</div>
\ No newline at end of file
+</div>
-diff -Naur src/desktop-0.4.1-5/src/app/templates/initializing.tpl src/desktop-0.4.1-5/src/app/templates/initializing.tpl
---- src/desktop-0.4.1-5/src/app/templates/initializing.tpl
-+++ src/desktop-0.4.1-5/src/app/templates/initializing.tpl
+--- desktop-0.4.1-5/src/app/templates/initializing.tpl
++++ desktop-0.4.1-5/src/app/templates/initializing.tpl
@@ -1,5 +1,5 @@
-<img class="icon-begin" src="/src/app/images/icon.png">
-<img class="init-icon-title" src="/src/app/images/popcorn-time-logo.svg">