summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2016-04-14 01:48:25 +0200
committergrufo2016-04-14 01:48:25 +0200
commit8a0d4e9d058b48497affdbfee18b4c4f20b56af4 (patch)
tree1c8a4cde64f37bd3948a5f6c6e65f34ff50ee614
parentbc5aa0870b8a304c981d6931b3e310cd33795a0d (diff)
downloadaur-8a0d4e9d058b48497affdbfee18b4c4f20b56af4.tar.gz
Fixed: "WARNING: Package contains reference to $srcdir"
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
-rw-r--r--popcorntime-ce.install2
3 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 370a9e2c041d..017511f36372 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,14 +8,16 @@ pkgbase = popcorntime-ce
arch = i686
license = GPL3
makedepends = npm
- depends = libnotify
+ depends = alsa-lib
depends = desktop-file-utils
- depends = ttf-font
depends = gconf
- depends = nss
- depends = libxtst
depends = gtk2
- depends = alsa-lib
+ depends = libnotify
+ depends = libxtst
+ depends = nodejs
+ depends = nss
+ depends = python
+ depends = ttf-font
optdepends = net-tools: necessary for the new vpn feature
optdepends = ttf-liberation: open source ttf fonts
provides = popcorntime
@@ -27,7 +29,7 @@ pkgbase = popcorntime-ce
source = popcorntime-ce.install
source = popcorntime-ce.desktop
sha1sums = c8a1e25fd777180942deb05d7a520f2313d95029
- sha1sums = 48fe37180e9dfed60da82fc67d023b0004f3f1c7
+ sha1sums = 2c22a3f1d1335abe8d7ac7dd6a33933720ba30e4
sha1sums = 219a9c7033361e1286967452868721302b1d6da7
pkgname = popcorntime-ce
diff --git a/PKGBUILD b/PKGBUILD
index 8dd88712b5cb..379cc79604b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch.
arch=("x86_64" "i686")
url="http://popcorntime.ag/"
license=("GPL3")
-depends=("libnotify" "desktop-file-utils" "ttf-font" "gconf" "nss" "libxtst" "gtk2" "alsa-lib")
+depends=("alsa-lib" "desktop-file-utils" "gconf" "gtk2" "libnotify" "libxtst" "nodejs" "nss" "python" "ttf-font")
makedepends=("npm")
optdepends=("net-tools: necessary for the new vpn feature" "ttf-liberation: open source ttf fonts")
provides=("popcorntime" "popcorntime-ce")
@@ -18,19 +18,23 @@ source=("https://github.com/PopcornTimeCommunity/desktop/archive/v${pkgver}-${pk
"popcorntime-ce.install"
"popcorntime-ce.desktop")
sha1sums=("c8a1e25fd777180942deb05d7a520f2313d95029"
- "48fe37180e9dfed60da82fc67d023b0004f3f1c7"
+ "2c22a3f1d1335abe8d7ac7dd6a33933720ba30e4"
"219a9c7033361e1286967452868721302b1d6da7")
_platform=$([ $CARCH = "x86_64" ] && echo "linux64" || echo "linux32")
-_pkgfullname="Popcorn-Time-CE"
+_execname="Popcorn-Time-CE"
_reldir="desktop-${pkgver}-${pkgrel}"
-_bindir="${_reldir}/build/${_pkgfullname}/${_platform}"
+_bindir="${_reldir}/build/${_execname}/${_platform}"
build() {
cd "${srcdir}/${_reldir}"
- npm install
+ npm install --user root
+
+ # Remove all references to ${srcdir}
+ find "${srcdir}/${_reldir}" -type f -print0 | xargs -0 sed -i "s|${srcdir}/${_reldir}|/usr/share/${pkgname}|g"
+
"${srcdir}/${_reldir}/node_modules/.bin/gulp" build -p ${_platform}
}
@@ -43,7 +47,7 @@ package() {
install -dm755 "${pkgdir}/usr/bin"
# Program
- install -Dm755 "${srcdir}/${_bindir}/${_pkgfullname}" "${pkgdir}/usr/share/${pkgname}/"
+ install -Dm755 "${srcdir}/${_bindir}/${_execname}" "${pkgdir}/usr/share/${pkgname}/"
install -Dm644 "${srcdir}/${_reldir}/"{CHANGELOG.md,LICENSE.txt,package.json,README.md} "${pkgdir}/usr/share/${pkgname}/"
install -Dm644 "${srcdir}/${_bindir}/"{icudtl.dat,libffmpegsumo.so,nw.pak} "${pkgdir}/usr/share/${pkgname}/"
@@ -51,7 +55,7 @@ package() {
cp -a "${srcdir}/${_reldir}/"{node_modules,src} "${pkgdir}/usr/share/${pkgname}/"
# Link to program
- ln -s "/usr/share/${pkgname}/${_pkgfullname}" "${pkgdir}/usr/bin/${pkgname}"
+ ln -s "/usr/share/${pkgname}/${_execname}" "${pkgdir}/usr/bin/${pkgname}"
# Desktop file
install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
diff --git a/popcorntime-ce.install b/popcorntime-ce.install
index c9556a82a6f8..156132729af4 100644
--- a/popcorntime-ce.install
+++ b/popcorntime-ce.install
@@ -1,7 +1,7 @@
post_install() {
update-desktop-database -q
echo
- echo "WARNING: Popcorn Time streams movies from Torrents"
+ echo "WARNING: Popcorn Time CE streams movies from Torrents"
echo "Downloading copyrighted material may be illegal in your country!"
echo "Use at your own risk!"
echo