summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormadmurphy2016-04-11 04:01:58 +0200
committermadmurphy2016-04-11 04:01:58 +0200
commitc995c0ee467b7426a6d09b096717102bdaccb0ed (patch)
tree73756001fdff72e26ca3a26f4dfee4d32f8390f8
parenta150732e9bdbac0ae75cb882e73deb633364d03a (diff)
downloadaur-c995c0ee467b7426a6d09b096717102bdaccb0ed.tar.gz
Fixed: "WARNING: Package contains reference to $srcdir"
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD22
2 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a25b6b0158f..370a9e2c041d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,9 +22,6 @@ pkgbase = popcorntime-ce
provides = popcorntime-ce
conflicts = popcorntime-ce-bin
conflicts = popcorntime-ce-git
- conflicts = popcorntime
- conflicts = popcorntime-bin
- conflicts = popcorntime-git
options = !strip
source = https://github.com/PopcornTimeCommunity/desktop/archive/v0.4.0-2.tar.gz
source = popcorntime-ce.install
diff --git a/PKGBUILD b/PKGBUILD
index e3502a8626d7..c4a6b0dff1ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ depends=("libnotify" "desktop-file-utils" "ttf-font" "gconf" "nss" "libxtst" "gt
makedepends=("npm")
optdepends=("net-tools: necessary for the new vpn feature" "ttf-liberation: open source ttf fonts")
provides=("popcorntime" "popcorntime-ce")
-conflicts=("popcorntime-ce-bin" "popcorntime-ce-git" "popcorntime" "popcorntime-bin" "popcorntime-git")
+conflicts=("popcorntime-ce-bin" "popcorntime-ce-git")
options=("!strip")
install="popcorntime-ce.install"
source=("https://github.com/PopcornTimeCommunity/desktop/archive/v${pkgver}-${pkgrel}.tar.gz"
@@ -25,25 +25,25 @@ _pkgfullname="Popcorn-Time-CE"
_reldir="desktop-${pkgver}-${pkgrel}"
_bindir="${_reldir}/build/${_pkgfullname}/linux$(if [[ $CARCH = 'x86_64' ]]; then echo '64'; else echo '32'; fi)"
-build() {
+package() {
- cd "${srcdir}/${_reldir}"
+ install -dm755 "${pkgdir}/usr/share/${pkgname}"
+ install -dm755 "${pkgdir}/usr/bin"
+ # Compile the program in its destination folder
+ mv "${srcdir}/${_reldir}/"* "${pkgdir}/usr/share/${pkgname}/"
+ cd "${pkgdir}/usr/share/${pkgname}"
npm install
- "${srcdir}/${_reldir}/node_modules/.bin/gulp" build
+ "${pkgdir}/usr/share/${pkgname}/node_modules/.bin/gulp" build
-}
-
-package() {
+ # Move both the source and the binaries back to their original path
+ mv "${pkgdir}/usr/share/${pkgname}/"* "${srcdir}/${_reldir}/"
cd "${srcdir}/${_bindir}"
- install -dm755 "${pkgdir}/usr/share/${pkgname}"
- install -dm755 "${pkgdir}/usr/bin"
-
# Program
install -Dm755 "${srcdir}/${_bindir}/${_pkgfullname}" "${pkgdir}/usr/share/${pkgname}/"
- install -Dm644 "${srcdir}/${_reldir}/package.json" "${pkgdir}/usr/share/${pkgname}/"
+ install -Dm644 "${srcdir}/${_reldir}/"{CHANGELOG.md,LICENSE.txt,package.json,README.md} "${pkgdir}/usr/share/${pkgname}/"
install -Dm644 "${srcdir}/${_bindir}/"{icudtl.dat,libffmpegsumo.so,nw.pak} "${pkgdir}/usr/share/${pkgname}/"
# Directories