summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormadmurphy2016-04-10 04:09:02 +0200
committermadmurphy2016-04-10 04:09:02 +0200
commitcf5bcffc6bdb790c02ba40074710cdf6f2c4a21d (patch)
treeda56fe8df8f656419a0450a2ebb814e57f510f81
parent9e80e621bb30425de5d68754e508b97618ab0a70 (diff)
downloadaur-cf5bcffc6bdb790c02ba40074710cdf6f2c4a21d.tar.gz
Switched from binary to source
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD60
-rw-r--r--popcorntime-ce.desktop6
3 files changed, 42 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5f6ed2210cb..5a25b6b0158f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = popcorntime-ce
arch = x86_64
arch = i686
license = GPL3
+ makedepends = npm
depends = libnotify
depends = desktop-file-utils
depends = ttf-font
@@ -18,17 +19,19 @@ pkgbase = popcorntime-ce
optdepends = net-tools: necessary for the new vpn feature
optdepends = ttf-liberation: open source ttf fonts
provides = popcorntime
+ provides = popcorntime-ce
+ conflicts = popcorntime-ce-bin
+ conflicts = popcorntime-ce-git
conflicts = popcorntime
conflicts = popcorntime-bin
conflicts = popcorntime-git
- conflicts = popcorntime-ce-git
options = !strip
- source = https://github.com/PopcornTime-CE/desktop/releases/download/v0.4.0-2/popcorn-time-community-v0.4.0-2-64bit.tar.xz
+ source = https://github.com/PopcornTimeCommunity/desktop/archive/v0.4.0-2.tar.gz
source = popcorntime-ce.install
source = popcorntime-ce.desktop
- sha1sums = ee6a1b9314cbcb8eeabe76e9d6928f8c0bee4f42
+ sha1sums = c8a1e25fd777180942deb05d7a520f2313d95029
sha1sums = 48fe37180e9dfed60da82fc67d023b0004f3f1c7
- sha1sums = 98cba5c0c979d37e601cc33cf3b562f106427d36
+ sha1sums = 219a9c7033361e1286967452868721302b1d6da7
pkgname = popcorntime-ce
diff --git a/PKGBUILD b/PKGBUILD
index 4b2cf9002e24..5c6873b987d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,61 @@
# Maintainer: grufo <madmurphy333@gmail.com>
pkgname=popcorntime-ce
-_pkgfamily=popcorntime
pkgver=0.4.0
pkgrel=2
pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch. Repos of the original community edition."
arch=("x86_64" "i686")
url="http://popcorntime.ag/"
-license=('GPL3')
-depends=('libnotify' 'desktop-file-utils' 'ttf-font' 'gconf' 'nss' 'libxtst' 'gtk2' 'alsa-lib')
-optdepends=('net-tools: necessary for the new vpn feature' 'ttf-liberation: open source ttf fonts')
-provides=('popcorntime')
-conflicts=('popcorntime' 'popcorntime-bin' 'popcorntime-git' 'popcorntime-ce-git')
-options=('!strip')
+license=("GPL3")
+depends=("libnotify" "desktop-file-utils" "ttf-font" "gconf" "nss" "libxtst" "gtk2" "alsa-lib")
+makedepends=("npm")
+optdepends=("net-tools: necessary for the new vpn feature" "ttf-liberation: open source ttf fonts")
+provides=("popcorntime" "popcorntime-ce")
+conflicts=("popcorntime-ce-bin" "popcorntime-ce-git" "popcorntime" "popcorntime-bin" "popcorntime-git")
+options=("!strip")
install="popcorntime-ce.install"
-sha1sums=('ee6a1b9314cbcb8eeabe76e9d6928f8c0bee4f42'
- '48fe37180e9dfed60da82fc67d023b0004f3f1c7'
- '98cba5c0c979d37e601cc33cf3b562f106427d36')
-
-_platform='64bit'
-
-if [ "$CARCH" = 'i686' ]; then
- _platform='32bit'
- sha1sums[0]='369da992f097e1b872a0f7d00a62361ac9192c93'
-fi
-
-source=("https://github.com/PopcornTime-CE/desktop/releases/download/v${pkgver}-${pkgrel}/popcorn-time-community-v${pkgver}-${pkgrel}-${_platform}.tar.xz"
+source=("https://github.com/PopcornTimeCommunity/desktop/archive/v${pkgver}-${pkgrel}.tar.gz"
"popcorntime-ce.install"
"popcorntime-ce.desktop")
+sha1sums=("c8a1e25fd777180942deb05d7a520f2313d95029"
+ "48fe37180e9dfed60da82fc67d023b0004f3f1c7"
+ "219a9c7033361e1286967452868721302b1d6da7")
+
+_pkgfullname="Popcorn-Time-CE"
+_reldir="desktop-${pkgver}-${pkgrel}"
+_bindir="${_reldir}/build/${_pkgfullname}/linux$(if [[ $CARCH = 'x86_64' ]]; then echo '64'; else echo '32'; fi)"
package() {
- cd "${srcdir}"
+ cd "${srcdir}/${_reldir}"
- install -dm755 "${pkgdir}/usr/share/${_pkgfamily}"
+ npm install
+ "${srcdir}/${_reldir}/node_modules/.bin/gulp" build
+
+ cd "${srcdir}/${_bindir}"
+
+ install -dm755 "${pkgdir}/usr/share/${pkgname}"
install -dm755 "${pkgdir}/usr/bin"
# Program
- install -Dm755 "${srcdir}/Popcorn-Time" "${pkgdir}/usr/share/${_pkgfamily}/"
- install -Dm644 "${srcdir}/"{icudtl.dat,libffmpegsumo.so,nw.pak,package.json} \
- "${pkgdir}/usr/share/${_pkgfamily}/"
+ install -Dm755 "${srcdir}/${_bindir}/${_pkgfullname}" "${pkgdir}/usr/share/${pkgname}/"
+
+ cp "${srcdir}/${_reldir}/package.json" "${srcdir}/${_bindir}"
+
+ install -Dm644 "${srcdir}/${_bindir}/"{icudtl.dat,libffmpegsumo.so,nw.pak,package.json} \
+ "${pkgdir}/usr/share/${pkgname}/"
# Directories
- cp -a "${srcdir}/"{node_modules,src} "${pkgdir}/usr/share/${_pkgfamily}/"
+ cp -a "${srcdir}/${_reldir}/"{node_modules,src} "${pkgdir}/usr/share/${pkgname}/"
# Link to program
- ln -s "/usr/share/${_pkgfamily}/Popcorn-Time" "${pkgdir}/usr/bin/${_pkgfamily}"
+ ln -s "/usr/share/${pkgname}/${_pkgfullname}" "${pkgdir}/usr/bin/${pkgname}"
# Desktop file
- install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgfamily}.desktop"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
# Icon
- install -Dm644 "${srcdir}/${_pkgfamily}.png" "${pkgdir}/usr/share/pixmaps/${_pkgfamily}.png"
+ install -Dm644 "${srcdir}/${_reldir}/src/app/images/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
}
diff --git a/popcorntime-ce.desktop b/popcorntime-ce.desktop
index 3b39b6356a01..b221e2318f52 100644
--- a/popcorntime-ce.desktop
+++ b/popcorntime-ce.desktop
@@ -1,8 +1,8 @@
[Desktop Entry]
-Name=Popcorn Time
+Name=Popcorn Time CE
Comment=Watch Movies and TV Shows instantly
-Exec=popcorntime %U
-Icon=popcorntime
+Exec=popcorntime-ce %U
+Icon=popcorntime-ce
MimeType=application/x-bittorrent;x-scheme-handler/magnet;
StartupNotify=false
Categories=AudioVideo;Video;Network;Player;P2P;