summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormadmurphy2016-03-10 02:36:06 +0100
committermadmurphy2016-03-10 02:36:06 +0100
commite1c6fc8afb42a9f6ae09dbf12d4935238e7cacb9 (patch)
tree1e54134e8c9de55291f19ec0e1be567798dd8b88
downloadaur-e1c6fc8afb42a9f6ae09dbf12d4935238e7cacb9.tar.gz
Popcorn Time Community Edition -- official popcorn time repos of the original community edition -- http://popcorntime.ag
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD57
-rw-r--r--popcorntime-ce.desktop10
-rw-r--r--popcorntime-ce.install12
4 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b2510fbce87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = popcorntime-ce
+ pkgdesc = Stream movies from torrents. Skip the downloads. Launch, click, watch. Repos of the original community edition.
+ pkgver = 0.4.0
+ pkgrel = 2
+ url = http://popcorntime.ag/
+ install = popcorntime-ce.install
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ depends = libnotify
+ depends = desktop-file-utils
+ depends = ttf-font
+ depends = gconf
+ depends = nss
+ depends = libxtst
+ depends = gtk2
+ depends = alsa-lib
+ optdepends = net-tools: necessary for the new vpn feature
+ optdepends = ttf-liberation: open source ttf fonts
+ provides = popcorntime
+ conflicts = popcorntime
+ conflicts = popcorntime-bin
+ conflicts = popcorntime-git
+ options = !strip
+ source = https://github.com/PopcornTime-CE/desktop/releases/download/v0.4.0-2/popcorn-time-community-v0.4.0-2-64bit.tar.xz
+ source = popcorntime-ce.install
+ source = popcorntime-ce.desktop
+ sha1sums = ee6a1b9314cbcb8eeabe76e9d6928f8c0bee4f42
+ sha1sums = 48fe37180e9dfed60da82fc67d023b0004f3f1c7
+ sha1sums = bf7c94bef131003ea940c78d053c536433e34cf5
+
+pkgname = popcorntime-ce
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3cc4d293246
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: grufo <madmurphy333@gmail.com>
+
+pkgname=popcorntime-ce
+_pkgfamily=popcorntime
+pkgver=0.4.0
+pkgrel=2
+pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch. Repos of the original community edition."
+arch=("x86_64" "i686")
+url="http://popcorntime.ag/"
+license=('GPL3')
+depends=('libnotify' 'desktop-file-utils' 'ttf-font' 'gconf' 'nss' 'libxtst' 'gtk2' 'alsa-lib')
+optdepends=('net-tools: necessary for the new vpn feature' 'ttf-liberation: open source ttf fonts')
+provides=('popcorntime')
+conflicts=('popcorntime' 'popcorntime-bin' 'popcorntime-git')
+options=('!strip')
+install="popcorntime-ce.install"
+sha1sums=('ee6a1b9314cbcb8eeabe76e9d6928f8c0bee4f42'
+ '48fe37180e9dfed60da82fc67d023b0004f3f1c7'
+ 'bf7c94bef131003ea940c78d053c536433e34cf5')
+
+_platform='64bit'
+
+if [ "$CARCH" = 'i686' ]; then
+ _platform='32bit'
+ sha1sums[0]='369da992f097e1b872a0f7d00a62361ac9192c93'
+fi
+
+source=("https://github.com/PopcornTime-CE/desktop/releases/download/v${pkgver}-${pkgrel}/popcorn-time-community-v${pkgver}-${pkgrel}-${_platform}.tar.xz"
+ "popcorntime-ce.install"
+ "popcorntime-ce.desktop")
+
+package() {
+
+ cd "${srcdir}"
+
+ install -dm755 "${pkgdir}/usr/share/${_pkgfamily}"
+ install -dm755 "${pkgdir}/usr/bin"
+
+ # Program
+ install -Dm755 "${srcdir}/Popcorn-Time" "${pkgdir}/usr/share/${_pkgfamily}/"
+ install -Dm644 "${srcdir}/"{icudtl.dat,libffmpegsumo.so,nw.pak,package.json} \
+ "${pkgdir}/usr/share/${_pkgfamily}/"
+
+ # Directories
+ cp -a "${srcdir}/"{node_modules,src} "${pkgdir}/usr/share/${_pkgfamily}/"
+
+ # Link to program
+ ln -s "/usr/share/${_pkgfamily}/Popcorn-Time" "${pkgdir}/usr/bin/${_pkgfamily}"
+
+ # Desktop file
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgfamily}.desktop"
+
+ # Icon
+ install -Dm644 "${srcdir}/${_pkgfamily}.png" "${pkgdir}/usr/share/pixmaps/${_pkgfamily}.png"
+
+}
+
diff --git a/popcorntime-ce.desktop b/popcorntime-ce.desktop
new file mode 100644
index 000000000000..7fe1b0a19336
--- /dev/null
+++ b/popcorntime-ce.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Popcorn Time
+Comment=Watch Movies and TV Shows instantly
+Exec=popcorntime %U
+Icon=popcorntime
+MimeType=application/x-bittorrent;x-scheme-handler/magnet;
+StartupNotify=false
+Categories=AudioVideo;Video;Network;Player;P2P;
+Type=Application
+Name[it_IT]=popcorntime-ce.desktop
diff --git a/popcorntime-ce.install b/popcorntime-ce.install
new file mode 100644
index 000000000000..c9556a82a6f8
--- /dev/null
+++ b/popcorntime-ce.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ echo
+ echo "WARNING: Popcorn Time streams movies from Torrents"
+ echo "Downloading copyrighted material may be illegal in your country!"
+ echo "Use at your own risk!"
+ echo
+}
+
+post_upgrade() {
+ post_install
+}